I'm trying to run a exe file that is located on my Vista partition, when I browse to the file and try to change the file to run as executable the tick box unticks itself right after i tick it, i tried running gksu nautilus but it does the same thing


This is likely because the Vista partition is using the NTFS filesystem and it was mounted with an fmask that does not permit setting execute permissions on files.

To fix this you need to manually mount the partition.

Details can be found on this post.

Here are the steps you need to take:

  1. Determine the drive's corresponding device by opening a terminal and typing: df
  2. The column on the far left is the device, and the column on the far right is the path for the drive. Find the device for the Vista partition.
  3. Unmount the Windows partition. (Click the eject button alt text that's next to it in Nautilus)
  4. Open a terminal
  5. Type the following:

    sudo mkdir /media/vista
    sudo mount -t ntfs -o fmask=0022,dmask=0000,uid=1000,gid=1000 \
        <DRIVE> /media/vista

    Replace <DRIVE> with your drive's device.

  • 1
    ive never had this problem before doing the same thing though, and that post is WAY too technical for me lol
    – Zabadda
    Dec 18 '10 at 18:43
  • @Zabadda: I added more clear instructions. Does that help? Dec 18 '10 at 18:56
  • ok df gives me this paste.ubuntu.com/545368
    – Zabadda
    Dec 18 '10 at 19:32
  • @Zabadda: Assuming you had it mounted at that point, your Vista device is /dev/sda1. Dec 18 '10 at 19:37
  • 1
    @Zabadda: The way it is now, you'll have to do that every time. But there is a way to do it so that it will always mount that way. That would probably be better as a second question though, as it involves some other work. Dec 18 '10 at 19:50

when using 10.04 running wine's .exes from a windows terminal worked alright, but now on 10.10 it just doesn't. I think it is a new security feature. Instead of running it from a windows partition transfer the files to your ubuntu filesystem, and run it from there. Works for me.


One other workaround is to enable the Wine PPA, since it disables the execute bit checking that the normal Ubuntu packages do.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.