I have installed ubuntu 10.10 and while I can launch it in fail safe graphics mode, I only get a text console when I try to launch it normally.

Apparently there is a problem with my drivers or something related. I updated all packages etc. in fail safe graphics mode, this did not help.

This is a copy of /var/log/Xorg.0.log: http://tom.pastebin.com/aqgXA9Ej

As you can see, it says:

[    69.197] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    69.206] (II) Module fbdevhw: vendor="X.Org Foundation"
[    69.206]    compiled for 1.9.0, module version = 0.0.2
[    69.206]    ABI class: X.Org Video Driver, version 8.0
[    69.206] (EE) open /dev/fb0: No such file or directory
[   119.528] (EE) intel(0): No kernel modesetting driver detected.
[   119.528] (II) UnloadModule: "intel"
[   119.528] (EE) Screen(s) found, but none have a usable configuration.
[   119.528]
Fatal server error:
[   119.528] no screens found

I tried adding video=S-VIDEO:d and nomodeset to grub launch command, these had no effect (found these suggestions on the web).

If I execute startX after logging in in this console, my screen becomes blank (well.. black) until I press the shutdown button of my laptop.

Some info:

lsmod |grep '^i' returns:

i915, i2c_algo_bit, intel_ips, intel_agp

dmesg | grep drm returns:

6.745490 drm initialized drm 1.1.0 20060810

lspci |grep VGA returns:

Intel corporation core processor integrated graphics controller (rev 02)

glxinfo | grep vendor returns:

server glx vendor string: SGI 
client glx vendor string: MesaProject and SGI 
openGL vendor string: mesa project

intel_reg_dumper > regdump_broke.txt returned:


dmesg returns:


Is there anything I can do to solve this issue?

I have tried to use the xorg-edgers PPA with the following commands to upgrade my Intel drivers:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get upgrade

However this did not resolve the issue.

Some information about my laptop, which I bought yesterday:

  • Name: Toshiba Satellite L670 1DT
  • Processor: Intel Pentium P6100 DualCore 2.0Ghz
  • Video card: build in, Intel HD Graphics Dynamic Video Memory Technology 5.0

I was told that this is a new Arrandale processor, with chipset HM55 (very recent apparently).



I figured it out. Apparently, it was a result of a chain of bugs and faults on my side. I do not fully understand why, but this should be semi true:

my windows 7 partitioning somehow corrupted a partition -> ubuntu installed on this partition -> installed kernel has a bug with my video card -> I updated kernel through fail safe graphic mode -> grub upgrade failed because of corrupted partition -> grub upgrade failure causes old kernel to be launched during boot -> old kernel intel graphics card bug remains

So, the fix was to repartition the drive and reinstall ubuntu, and update kernel through fail safe graphic mode.

The kernel upgrade was the actual fix for the general issue, also described by this bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/648631


  • nicely done, the bug would be pain in the azz... and damn you windoze :P – danizmax Dec 19 '10 at 9:11

Looks like a bug in intel driver, what I see from dmesg:

[ 7.012557] BUG: unable to handle kernel NULL pointer dereference at 0000000000000008

and after that there is a stack trace from crash. Not sure what module exactly crashes.

It's also weird that you have no frame buffer device, must be missing because of the crash:

[ 69.206] (EE) open /dev/fb0: No such file or directory

  • Thanks, I actually figured out why this was not resolved by a kernel upgrade (it actually is, but not shown by grub because of corrupted partition), see my answer. – Tom Dec 18 '10 at 20:42

Fwiw, nomodeset isn't available for the -intel driver, because Intel removed it. You can only use kernel modesetting with the -intel driver.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.