I have followed various recommendations from the Ubuntu Documentation to create a bootable Ubuntu USB flash drive using the 12.04.1 Alternate install ISO-file for 64-bit PC. But the integrity test of the USB stick has failed and I do not see why.

These are the steps I have made:

  1. Download of the 12.04.1 Alternate install ISO-file for 64-bit PC (ubuntu-12.04.1-alternate-amd64.iso) from http://releases.ubuntu.com/12.04.1/, as well as the MD5, SHA-1 and SHA-256 hash files and related PGP signatures
  2. Verification of the data integrity of the ISO-file using the MD5, SHA-1 and SHA-256 hash files, after having verified the hash files using the related PGP signature files (see e.g. https://help.ubuntu.com/community/HowToSHA256SUM and https://help.ubuntu.com/community/VerifyIsoHowto)
  3. Creation of a bootable USB stick using Ubuntu's Startup Disk Creator program (see http://www.ubuntu.com/download/help/create-a-usb-stick-on-ubuntu)
  4. Boot of my computer using the newly made 12.04.1 Alternate install on USB stick
  5. Selection of the option "Check disc for defects" (see https://help.ubuntu.com/community/Installation/CDIntegrityCheck)

Steps 1, 2, 3 and 4 went without any problem or error messages. However, step 5 ended with an error message entitled "Integrity test failed" and with the following content:

The ./install/netboot/ubuntu-installer/amd64/pxelinux.cfg/default file failed the MD5 checksum verification. Your CD-ROM or this file may have been corrupted.

I have experienced the same (might only be similar since I have no exact notes) error message in previous attempts using the 12.04 (i.e. not the maintenance release) Alternate install ISO-file. I have in these cases tried to install anyway and have so far not experienced any problems to my knowledge.

  • Is failed integrity check described above a serious error?
  • What is the solution?
  • Or can it be ignored without further problems?
  • I wonder if you are not just attempting to run a physical media (CD or DVD) test on a USB (flash memory) device, and have step beyond what the test was intended to do. A 'defect' in 'burning' can not really be present on a solid-state digital storage device. QUESTION: Does the USB device appear to still correctly operate, and install Ubuntu? – david6 Aug 25 '12 at 8:56
  • @david6 Yes, the USB device and a subsequent Ubuntu installation (of 12.04, have not tried 12.04.1 yet) seam to appear correctly. That is what I meant with writing "I have [...] tried to install anyway and have so far not experienced any problems to my knowledge." – mghg Aug 25 '12 at 10:06
  • As per answers above, this is a bug and could be ignored in some cases. – Braiam Oct 5 '13 at 1:21

This is an error in mastering the ISO, but can safely be ignored

  • You get this error because the install/netboot/ubuntu-installer/amd64/pxelinux.cfg/default file does not exist in the 64-bit alternate ISO image, although it does in the ISO's file-checksum list (md5sum.txt):

    • 573bf62a1f14cdcef0e8299863547a5a ./install/netboot/ubuntu-installer/amd64/pxelinux.cfg/default

    • See this pastebin for the actual contents of the install/netboot folder.

  • It can be ignored because the files refer to the minimal "netboot" ISO version, which is irrelevant when you are using a full alternate ISO.

  • If you really want to "solve" the error, you can download the missing file into the appropriate folder; beware that this may not be the last though because apparently there are six such missing files...

|improve this answer|||||
  • 1
    Thanks for the answer. However, I do not understand why a checksum list includes a file that is not included in the ISO image. I am using Ubuntu at work for enterprise purposes and wanted to be as ensured as possible that the installation media is without any error. I thus liked the "Check disk for defects" option but it seems strange that it is impossible to get a positive result from the test. – mghg Aug 25 '12 at 10:19
  • @mghg. I totally agree with you. I am also trying to install Ubuntu in a corporate network and a simple integritycheck seems almost mandatory to me. Maybe our feedback will help in resolving this issue. – user87249 Sep 3 '12 at 12:07
  • Incredible, I'm doing an alternate install by writing this iso to a usb stick using unetbootin and I get the same failures. Doing an md5sum -c md5sum.txt will list the missing files – Juan Nov 6 '12 at 3:52

This stopped my installation dead in its tracks doing an alternate install with an encrypted volume. Using unetbootin to create the image, the six files mentioned above were missing. I am convinced this is an issue with filename and path length restrictions causing these long filenames to be missing. This issue is marked as an invalid bug here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1041911

Ultimately adding the files didn't help. And I had to boot into an incomplete installation and install ubuntu-desktop manually.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.