I cannot connect to a wireless network, and am continually asked for the network password.

I have tried countless suggested solutions on the different locations I've already referred to. None of them have worked.

Details of my experience are as follows:

I have just recently installed Ubuntu 12.04.1 (32-bit). Ubuntu installed on my system seemingly fine, and I even formatted my hard drive during the process. It's as if it were a new desktop computer.

During the installation I was asked to connect to a Wireless Network. I have a USB Wireless Card connected which I have used to connect desktop PC's, laptops, and a Wii to the internet from approximately the same area of the house (thus the same distance from the Wireless Router). I chose my network, entered the correct password for it (I double checked; it's definitely the right password) and proceeded with the installation. Several times before the installation was complete, I was asked to authenticate the connection, and this seemed to do nothing each time. On the repeated screens the password was already entered in the appropriate box.

When Ubuntu booted up the first thing I was faced with (other than something about Language settings, or something) was another request for authentication. Again, the password was already there, so I clicked connect. It did not connect. Instead, I was once again faced with repeated requests every few minutes.

I went onto my laptop, which is connected to this network, checked the details of the network, and entered them manually into my Ubuntu PC (including the IPv4 and IPv6 information) but this didn't work either, so I set it back to finding the settings automatically. Note, also, that the "Connect automatically" and "Available to all users" boxes are checked, and have been unchecked & rechecked countless times. I have also tried having my User account connect automatically, and to need a password entered at the welcome screen.

Whilst I've been writing this, it has gone through a spat of connecting successfully to the network for less than a minute, before coming offline again, only to repeat the process. But it has now returned to prompting me for a password every couple of minutes.

This computer has already run on the Fedora OS, and had no trouble connecting to, and maintaining a connection. I also have a laptop running Windows 7 less than a metre away from this desktop PC, which is connected and has no trouble maintaining a connection at 50%-100% strength (fluctuating).


  • I know it's not the wireless card
  • I know it's not the PC itself
  • I know it's not the access point
  • I know it's not the location of my PC or wireless card
  • It is solely because of Ubuntu

Everything else has worked fine, but the moment Ubuntu was introduced into the equation, it has gone completely wrong. Honestly; I prefer Ubuntu as an OS to Fedora, but if I can't solve the problem it'll be straight back to Fedora that I'll have to go.

Can anyone help me at all?

  • If it used to work on "old fedora" that doesn't necessarily indicate it works on "new fedora". It could be a bug in the wireless driver with 3.x kernels (I suspect it is). You could try it under 10.04 LTS or Ubu running a 2.x kernel and see if it still evidences. If that fixes the problem, file a bug or subscribe to one (since in all probability you aren't the first one). Aug 25, 2012 at 2:11
  • I am facing this exact same issue. I don't have a previous OS install to compare to, but the frequency of connection requests has been rising steadily for the last 2 weeks until now when I come back to my computer after an hour, I have to clear a dozen authentication boxes.
    – Hellion
    Oct 24, 2012 at 2:02

3 Answers 3


Click the NM applet on the panel. Then select "Edit Connections...". In the Wireless tab of the dialog, select and delete the connections in question (or all of them). Save and close the dialog. Click the NM applet on the panel again and select the wifi name that previously not be able to connect. If you can't see the name that you want, try finding it in "More networks". Hope this can help. (Writen on 20130222)
(Editted on 20130226) It was a shame that I did not check the connection thoroughly. The connection type was ad-hoc (which was not infrastructure type) so it did not work the way it usually did. Sorry. (Writen on 20130226)
Since I have BCM43228, I followed NikTh's suggession in http://ubuntuforums.org/showthread.php?t=2084508&highlight=BCM43228 and got connected. However, I did not know what really caused the problem and when because I was working in a not stable environment. The AP worked on and off and the computer got new update continually. That was why I could not reallized when the connection changed from working fine to not working. (Writen on 20130226 + about 2 hrs after the first edition)
I have to say sorry again for the problem has come back after I disabled wireless connection and used wired connection for printing jobs. I have to do more research or go back to Lucid. Sorry for not a good answer. (Writen on 20130226 + about 5 hrs after the first edition)
After a short research I found and followed http://pkgs.org/ubuntu-12.04/ubuntu-multiverse-i386/broadcom-sta-common_5.100.82.112-4_all.deb/download/. After restarting and did an off and on on a Enable Wireless it connected. This gave me a bit better feeling even though the connection was set to connect automatically. I also found that I got different IP every time I managed to connect. The university dhcp server remembers a served IP and always serves the same IP if the computer reconnects within 5 days. I meant I was not sure this would solve the problem instantly. (Hope this is the last edition)
The time I posted these messages was about 24 hours after the (hopefully) last edition. The connection was made in the condition that (1) the computer was shutdown previously with wireless disabled status and (2) no LAN cable was connected to the computer when starting up. What I did was enabling the wireless via NM's menu and got connected. This might not be a good answer but it could be a work-around.
This post was done 16 hours later (20130228:0230 UTC). Now what I said to be a work-around could be promoted to be an answer. The computer must not be connected with a LAN cable. The status of wireless connectivity when previously shutdown was not a matter. What really to be done when started up was enabling the wireless network. If the wireless was enabled you might see the NM applet blinks endlessly. In such a situation, just disable it and enable it back again and you'll be fine.


I had the same problem: new Ubuntu version caused endless password authentication requests. The workaround of deleting the connection helped BUT ONLY WITH RESTARTING THE COMPUTER. In other words, I first deleted the connection. Then, I restarted the computer. Then, I added the connection again. Adding the connection without the restarting caused endless trying by the system to connect after it asked for a password. No successful connection followed without restarting the computer.

  • Tried that on Ubuntu 13.10 without success.
    – Wernight
    Dec 28, 2013 at 20:11

System Settings -> Network (-> Forget Network) -> Type/Select desired network Name / SSID (in the Network name box) -> Options (lower right corner) -> Wireless security (4th tab) -> Enter Key -> select "save" ( -> Restart).

Not the answer you're looking for? Browse other questions tagged or ask your own question.