12

When I am in English, Ctrl+C, Ctrl+V works fine when I need to copy paste. But when I turn to Greek, Ctrl+C and Ctrl+V and basically no shortcut almost works in Greek. So each time I have to alt shift and go back to English in order to user Ctrl+C to copy something. How can I apply this to the Greek keyboard profile?

EDIT

I also realized that when using NetBeans IDE 7.4, I can copy and paste in Greek but I can't use the tonic system of the language over the words. In Aptana studio I can't use Copy and paste Ctrl+C, Ctrl+V When using gedit everything works fine. Different software use different keyboard layout settings?

  • Weird, I cannot reproduce this! Do you have any custom setting that you have altered that may cause this? – hytromo Aug 25 '12 at 8:43
  • 1
    hmmm Not that I am sure, but I suspect that this happens in eclipse. Now that I am here typing you this message, it seems to work... but in Text Editor, and Eclipse it seems that it does not work.. . . . . – themhz Aug 25 '12 at 13:21
  • Still I cannot reproduce it with the Text Editor. Weird. – hytromo Aug 25 '12 at 13:28
  • maybe my eclipse and my textpad binds those keys and overides its current ability to change language? is their a way to tell? – themhz Aug 25 '12 at 14:52
  • when ever I install eclipse it does that. When eclipse is not on it works also in the text editor. When I remove the program everything seems to be ok . Is there any place I can check the key bindings? Is it a Global scope place or an application scope only? – themhz Aug 31 '12 at 12:15
4

This is a known bug:

https://bugs.launchpad.net/unity/+bug/1226962

I recommend you subscribing to it to receive updates and marking it as affecting you to increase the bug "heat" score.

Workaround for some system hotkeys and two layouts (English and non-Latin): rebind all hotkeys in your local layout. For example instead of Ctrl+Alt+T use Ctrl+Alt+τ (Greek tau). That hotkey still works with the English layout. If you use English and two different non-Latin layouts this workaround helps only with one of them.

7

As said above this is a known bug, however there is a simple fix shown here:

https://gist.github.com/d3zorg/3f71ee24b1a0a288ce27

sudo add-apt-repository ppa:attente/java-non-latin-shortcuts
sudo apt-get update
sudo apt-get upgrade
restart unity-settings-daemon

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.