I'm using Acer 4530 with Suyin webcam. The webcam can be detected but not showing anything. Before I start anything, I ran lsof /dev/video0 to make sure nothing is using the camera, and I started Cheese but the screen shows black and nothing.

I execute lsof /dev/video0 again and it shows Cheese is using it. I exited cheese and opened up VLC. The device showed in the playlist but not the image that the camera used to show.

Long time ago, it was running fine, but after that it stop working and then my graphic card are down. After the graphic card fix, the webcam came up again but now it stop working again.

Is there any hardware problem or it's just software problem?


Hey I have the exact same problem with my Acer, with the Suyin camera. It is detected but show black. It has been working the first three weeks I change to Linux and now it show black. I don't know what to do... Sorry I am not helpful but you are not alone.


"cheese" is unfortunately a very poorly written software. And, unfortunately, there is no really decent camera software on Ubuntu ("guvcview" and others have some +s but still far from panacea). Bugs, cheap design and lack of options may be discouraging.

Some suggestions anyway

  • do lsusb to see if you webcam is detected in the USB port

  • In cheese / Preferences, ensure the video is set to your webcam. Also try lower resolutions first.

  • run dmesg in a terminal as your usual user (the one running cheese), and try again. This one is weird! Worked after I first connected a different cam ; it seems cheese or the driver (...) keeps some remanent data and removing / connecting a different cam makes the poor software lost in space. Running dmesg (I know it's weird) was enough to clean some buffers(?).
    Found here.

  • try to run cheese as root sudo cheese - if it works, you may have access problems (eg like in /dev/video*)

  • try with guvcview, with vlc... If that works, maybe cheese settings are at fault.

  • more options

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.