2

Since I upgraded to Ubuntu 12.04 gvfs-mount does not work with FTP anymore. Trying to connect to a FTP-server using Nautilus or

  gvfs-mount "ftp://user@server.de/"

I get the following error message:

  Error mounting location: Error resolving '': No address associated with hostname

Connecting via SSH or other protocols works well. The problem occurs only with my current user. That means it can't be an issue with the FTP-Server. So I tried to delete all gvfs config files with:

  sudo apt-get purge gvfs

and after that reinstalled it. But this did not change anything. What else could I do? Please help.

5

I found the answer here: https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/1018806 The problem results from wrong configuration of system wide proxy. If you have the same problem you can try following commands, that will reset your proxy settings to default:

gsettings set org.gnome.system.proxy autoconfig-url ''
gsettings set org.gnome.system.proxy ignore-hosts ['localhost', '127.0.0.0/8']
gsettings set org.gnome.system.proxy mode 'none'
gsettings set org.gnome.system.proxy use-same-proxy false
gsettings set org.gnome.system.proxy.ftp host ''
gsettings set org.gnome.system.proxy.ftp port 0
gsettings set org.gnome.system.proxy.http authentication-password ''
gsettings set org.gnome.system.proxy.http authentication-user ''
gsettings set org.gnome.system.proxy.http enabled false
gsettings set org.gnome.system.proxy.http host ''
gsettings set org.gnome.system.proxy.http port 8080
gsettings set org.gnome.system.proxy.http use-authentication false
gsettings set org.gnome.system.proxy.https host ''
gsettings set org.gnome.system.proxy.https port 0
gsettings set org.gnome.system.proxy.socks host ''
gsettings set org.gnome.system.proxy.socks port 0
  • gsettings set org.gnome.system.proxy mode 'none' worked for me. It was set to auto before. – topher Apr 13 '14 at 10:02
  • it backs again after reboot. How to make it works permanently? – bagustris Feb 24 '16 at 11:53
-1

Tut mir leid, but that looks more like an error in host resolution than a problem with gvfs-mount. gvfs-mount with FTP works fine for me.

Please make sure that the regular ftp client works:

ftp server.com
  • The Server works well. I have more then ten FTP-Server and each works well via nautilus or gvfs mount using an other account, an other machine or an other client like FileZilla. This is not an issue with the sever. – user5950 Aug 23 '12 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.