I started to use Ubuntu two weeks ago, I still have some difficulty in understanding the whole world of Linux.

I'm in front of the following scenario:

I have a Windows computer running 12.04 in a VirtualBox, I've installed in Ubuntu samba and proftpd, because I've limited the Ubuntu HD to 8GB. I had the idea to use a shared Windows folder to use as my main FTP storage place.

In /etc/fstab I've added the following line

//$/ /mnt/FTP cifs user,umask=0022,gid=0,uid=0,suid,username="####",password=##### 0 0

I can mount my partition with mount /mnt/FTP, I can access, but I cannot create anything in the directory.

The permission of the directory is dr-xr-xr-x 0 root root.

I want to have the permissions, but how can I do it?

Was my fault to not test direct by Linux before posting, I've verified if I could create or change anything direct in ssh while I was writing, first of all I've tested using FTP.

I've tried right now to chmod -R 777 /mnt/FTP, and I got permission denied error, I'm logged in my virtual Linux with ssh.

I've unmounted the /mnt/FTP and I could chmod 777 the folder, but the permission of the containing files inside the /mnt/FTP still dr-xr-xr-x.

And can't change their permissions. How can I solve this problem?

  • Directory permissions are set with the CHMOD command. Here's a wiki article on it - en.wikipedia.org/wiki/Chmod - There's some helpful commands and some explanation on what you're seeing when you see dr-xr-xr-x or any variation thereof. – SQLSavant Aug 23 '12 at 1:55
  • Why are you using the word FTP at all? It's a Samba share and has nothing to do with FTP. – Sergey Aug 23 '12 at 2:18

I'm a new user and Linux is a bit complicated yet to me. I think I found the solution dir_mode=0777, file_mode=0777 in the /etc/fstab.

My problem is now solved. The problem was the permission in the fstab.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.