7

How do I set the default user session to XFCE4?

I have tried:

sudo /usr/lib/lightdm/lightdm-set-defaults --session xfce

sudo /usr/lib/lightdm/lightdm-set-defaults --session xfce4

sudo /usr/lib/lightdm/lightdm-set-defaults --session xubuntu-desktop

I am using xRDP and do not have access to the normal greeter.

8

I created file ~/.xsession with a one liner xfce4-session.

3

It works with xfce4-session.

sudo /usr/lib/lightdm/lightdm-set-defaults --session xfce4-session
  • 1
    /usr/lib/lightdm/lightdm-set-defaults seems to be missing in ubuntu 14.04 :( – user48956 Apr 5 '16 at 23:35
1

On Ubuntu 16.04.1, I installed xubuntu-default-settings and it works fine. Now I can login in xfce by default.

sudo apt install xubuntu-default-settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.