I'm trying to get 12.04 LTS 64-bit up and running on a Dell PowerEdge T300 Server with the Dell SAS 6/iR RAID controller (LSI SAS1068E chipset).

Ubuntu installs just fine, doesn't report any errors, sees the RAID mirrors as drives, everything seems normal, but fails to boot up after the installation. It reports no boot device. The /boot partition is on /dev/sda1 and is marked as bootable, and when I installed Ubuntu, I told it to install grub to the MBR.

Any suggestions for what I should check next?


I have a similar problem with a Dell PowerEdge SC440 with the Dell SAS 5 controller. I wanted to upgrade my hard disks from 2x160 GB in RAID-1 (mirroring) to 2x2TB in RAID-0 (striping). Creating the "virtual disk" worked, installing Ubuntu as well, but after rebooting the BIOS doesn't recognise the "virtual disk" as a bootable device.

So, in my case, the problem is not with OS installation, but with the SAS and BIOS "integration". In the Setup Utility, under Boot Order, you should see an entry with something like (in my case) "#0240 ID00 LUN0 Dell VIRTUAL". If you don't see this, the problem is not with Ubuntu, but with SAS/BIOS.

I got things working by reconfiguring the drives in RAID-1. The BIOS then picked up the virtual drive and booting works.

Sorry I don't have an immediate solution for you, but I hope it helps troubleshooting your problem.

Cheers, bert


I want to share with you my experience with ubuntu 14.04 under DELL Poweredge T110.

I have not a raid configuration, i wanted to add just more space so i added a new SAS Disc (450 GB - 15000 RTM) and evry time i connect the new disc, ubuntu won't to start (i got: initramfs)...

After weeks of searching the reason, i discovred that DELL SAS Controller is very slow to start, so ubuntu could not see the new disc properly, That was the reason.

How did i solved this ?

Simply by: changin the rootdelay value in grub linke this:

sudo nano /etc/default/grub

Then update the grub:

sudo update-grub

finally, reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.