I had very strange issue , I rebooted my PC (Ubuntu 10.10) , when the login screen comes back, what ever user I select it expands the password field and collapses it again in less than 1 second.

Some services like ssh , vnc don't work so I can't login to it remotely, however I can login in tty but still can't login via GDM.

I tried to reinstall gnome via sudo apt-get install --reinstall gnome-desktop and many other command about reconfigure gnome , but nothing help.

I recorded a video of the problem via my mobile camera (sorry about the low quality )

some of my error logs xserver log and its the same in the startup error log :

(ww) warning , couldn't open module nvidia 
(EE) Failed to load module 'nvidia' ( module doesn't exist , 0 )
(EE) no drivers avaliable 

fatal server error : 
no screens found 

and now i was stuck in the recovery mode ,

normal mode isn't working any more

2- in the recovery mode + failxsafe : i had tried to create a default configuration for my hardware and after a reboot , with no luck the same problem again .

3-i had tried to reinstall nVidia driver as Jorge suggested in these setps :

sudo apt-get install nvidia-glx-96  /// i took a while 

sudo nvidi-setting -r to write new config

and after reboot nothing changed

4- i tried to install sudo apt-get install nvidia-173 and after reboot the same error ,

i ran sudo nividia-setting and the new error was

ERROR : the control display is undefined , please run nvidia-setting --help for usage information

5- beofore this problem i was having this bug , but i wasn't know any thing about it :

Screen Blanks/Monitor Turns Off
Using a laptop with a GeForce Go card, or connecting the sole display via DVI on a dual-head system sometimes results in the screen not receiving a picture. This is caused by the driver outputting video to the VGA port on the graphics card, instead of DVI.

The usual hint that you have this problem is when you hear the startup sound but nothing appears on the screen. If you do not hear any sound, you are more than likely experiencing unrelated problems.

This is a launchpad bug about displays on digital outputs being blank when using NVIDIA binary driver, and can be resolved by editing your /etc/X11/xorg.conf file:

Switch to the console (Try using ctrl+alt+F1, or reboot and select recovery mode from the GRUB menu.)
Use your text editor to open /etc/X11/xorg.conf. (try sudo nano /etc/X11/xorg.conf)
Find the line that says Section "Screen"
Insert a new line that says Option "UseDisplayDevice" "DFP".
Save the file. If you had to restart into recovery mode, type reboot, otherwise restart your display using sudo /etc/init.d/gdm restart.

and i went to vim /etc/X11/xorg.conf and tada the file is empty . and ubuntu had backup file called xorg.conf.backup , so i went to replace it and reboot ....... same error in the video .

Any help or suggestion is really appreciated.

  • My guess is that SSH and VNC probably do not work because you usually will not be connected to a wireless network until you log in to a user. This is because every user have their own set of wireless networks to connect to, and not a shared list. VNC wouldn't work anyway, as it is activated first when you have logged in to a user that has enabled it. You can, however, press Ctrl + Alt + F1 to enter the command line locally (and Ctrl + Alt + F7 to switch back). – Frxstrem Dec 17 '10 at 13:50
  • My login screen does that if I hold down the Esc key the whole time. I wonder whether disconnecting the keyboard would change anything. – ændrük Dec 17 '10 at 20:18
  • @ændrük , i had disconnect one of (keyboard , mouse ) each time and still the same , its not an hardware issue – tawfekov Dec 17 '10 at 23:04
  • Please put your /etc/X11/xorg.conf on pastebin.ubuntu.com and paste the link here. – Jorge Castro Dec 18 '10 at 16:11
  • pastebin.ubuntu.com/545352 – tawfekov Dec 18 '10 at 18:58

It looks like your nvidia drivers didn't get updated when your kernel got upgraded; this can happen if you install drivers by hand or via the website.

You can reinstall the nvidia drivers by running jockey-text in a console. From here you can list the available drivers and install them.

jockey-text -l will list the available drivers:

jockey-text -l
xorg:nvidia_173 - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)

And then you can enable them with the -e flag, for example:

jockey-text -e xorg:nvidia_current or jockey-text -e xorg:nvidia_173

| improve this answer | |
  • Yeah... that happened to me yesterday. I simply re-ran the installation binary from nVidia and that fixed it. And for the record, it was a kernel/kernel-module version mismatch. – Nathan Osman Dec 18 '10 at 0:39
  • Many Thanks Jorge for your efforts , you rocks ! , to be honest i end up with re installing it – tawfekov Dec 26 '10 at 21:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.