I have a Fujitsu ScanSnap S1300i. I compiled SANE from source. When I run sane-find-scanner, the following output is given:

sane-find-scanner will now attempt to detect your scanner. 
If the result is different from what you expected, first make sure your scanner 
is powered up and properly connected to your computer.
No SCSI scanners found. If you expected something different, make sure 
that you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04c5, product=0x128d) at libusb:002:004  
Your USB scanner was (probably) detected. It may or may not be supported by SANE.
Try scanimage -L and read the backend's

Not checking for parallel port scanners.
Most Scanners connected to the parallel port or other proprietary ports can't be detected by this program.
You may want to run this program as root to find all devices. 
Once you found the scanner devices, be sure to adjust access permissions as necessary.

However, when I run scanimage -L or sudo scanimage -L the following output is given:

No scanners were identified. If you were expecting something different. 
Check that the scanner is plugged in, turned on and detected by the sane-find-scanner tool (if appropriate). 
Please read the documentation which came with this software (README, FAQ, manpages).

Also, I added an entry to /etc/sane.d/fujitsu.conf for the ScanSnap S1300i.

2 Answers 2


From what I see on the official sane page, the ScanSnap S1300 uses the epjitsu, not the fujitsu backend. You could try moving the configuration entry from fujitsu.conf to epjitsu.conf file in the same folder.

I'm not sure what exactly are the differences between the S1300 and S1300i, so you may have to extract the *.nal firmware file from the Fujitsu Windows driver like it says in the header of both fujitsu.conf and epjitsu.conf files in /etc/sane.d/, if you haven't done that already.

Update I just remembered when I built sane from source because I needed the new version for my scanner to function, I had to create a new udev rule for the scanner to be usable.

Created a new file in /etc/udev/rules.d called 40-libsane.rules and add the following line to the file:

ATTRS{idVendor}=="AAAA", ATTRS{idProduct}=="BBBB", ENV{libsane_matched}="yes"

Replace the AAAA and BBBB with the IDs of your scanner. You can see them by typing lsusb (actually it's the same IDs you said you used to create a new entry in fujitsu.conf).

  • Thanks for the response. Unfortunately I don't have an installation of Windows or OSX, so I can't extract the .nal file from the driver. Is there a way to do it without installing the driver? I have the installation CD that came with the scanner on my desk.
    – Zach Latta
    Aug 22, 2012 at 8:29
  • It says that the file usually resides inside a .cab file. You could try searching the folders and archives on the CD. Also see my edited answer, I just remembered something else I needed to do.
    – jeremija
    Aug 22, 2012 at 8:54
  • 1
    @Crynix thanks that would be great as I've tried compiling sane backends from src from different versions in git and no luck. I should also mention that I'm using the pre-installed sane from 12.04 though I don't think that would make a difference. And I assume also you used the 1300i_0D12.nal firmware file?
    – Maks
    Mar 12, 2013 at 0:31
  • 1
    @ZachLatta I know its been a while but did you ever get a chance to setup your scanner again and note down how you got it working?
    – Maks
    Aug 23, 2013 at 5:25
  • 1
    See askubuntu.com/questions/567863/… for the answer to a similar question.
    – Beef Eater
    Jun 22, 2016 at 19:08

This might be a pretty esoteric addition, but i had the same problem and non of the solutions that i found worked for me. The strange thing was that the scanner (scansnap 1300) worked fine in gscan2pdf, it just wasnt showing on scanimage -L and (therefore?) scanbd failed to register a thread for the button activity. At some point i fired

SANE_DEBUG_DLL=3 scanimage -L

to analyse the output.. and for some strange reason than the problem was gone. And scandb also started working after that. Kind of a heisenbug (one that doesnt happen when you look). :shrug:

I also fired

udevadm control --reload-rules;udevadm trigger

before (but im pretty sure i already did that before and it didnt helped, i also restarted once after adding the udev rule). Maybe someone finds this helpful

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.