I have searched around the net for a solution to my problem. I gave myself an account user name for facebook so I could use the chat in Pidgin 2.10.3. However, no matter what I do, Pidgin refuses to enable the account and it gives me the same message:

username@chat.facebook.com/Pidgin disabled Not Authorized

I used the tutorial on at this blog: http://poppleit.com/how-to-howto-use-facebook-facebookchat-facebook-chat-with-pidgin-instant-messenger-14-07-2012/#comments

The settings have changed recently.

open pidigin accounts and edit the facebook account to the following:

Protocol: XMPP

Username: xyz (This might not be the username that you enter at facebook login page - But the one which you see on your timeline link - https://www.facebook.com/xyz)

Domain: chat.facebook.com

Resource: Pidgin (this is what is missing most of the time)

Password: xyx

Local alias: xyz

On the advanced tab:

Connect port: 5222

Connect server: chat.facebook.com

  • 1
    Since May 2015 this solution no longer works. On both windows and linux the purple-facebook plugin can be used: github.com/jgeboski/purple-facebook/wiki – Wouter Oct 12 '15 at 13:34

Since nobody else has posted this as an answer...

As of May 2015, facebook chat no longer uses XMPP so you can't just use that to connect in pidgin.

Instead, try this plugin: https://github.com/jgeboski/purple-facebook/wiki

Facebook itself has a page to help set up several chat clients https://www.facebook.com/sitetour/chat.php (or Help search your chat client)

While signed in to Facebook, choose your chat client and you will get a pop-up window telling you the exact settings to enter based on your Facebook login. (for example, username is not the same as what you use to sign into Facebook...)

And just to restate the obvious, I got the "not authorized" after I did the above and realized I had missed a character entering my password...

  • 2
    Since May 2015 this solution no longer works. On both windows and linux the purple-facebook plugin can be used: github.com/jgeboski/purple-facebook/wiki – Wouter Oct 12 '15 at 13:35
  • 1
    Link in this answer redirects me on messenger.com. – Tomáš Zato Oct 11 '16 at 12:52

I was finally able to find the missing step in solving this:

Apps needs to be enabled on: https://www.facebook.com/settings?tab=applications&section=opt_out

Be sure to go through all of this 'App' page and uncheck anything you don't need (i.e. everything).

For the record:

Good luck!

I'm able to connect from Pidgin to my FB profile, but I couldn't for a friend!

The problem is that my friend has a very long password with a special characters which seems not apparently be accepted by Pidgin (he used the French character ç)

So I reduced password length and delete that strange character, and it works!

If you're obliged to use special characters try the common ones like _ or - or & etc.

Have a nice day!

When being behind a proxy (not sure if the same for each and every network/proxy config out there) it's worth to try changing "connect port" as well - from default 5222 to 443. This was something that I had to do in order to get it working at my workplace.

So the full config would be:

Basic tab:

 Username: *xyz* (the one that leads to your profile with link like this: http://facebook.com/xyz)
 Domain: *chat.facebook.com*
 Resource: can be blank or *Pidgin* as suggested in facebook's docs
 Password: *your-facebook-password*

Advanced tab:

Connection security: *Require enctryption*
Allow plaintext auth over unencrypted streams: *unchecked*
Connect port: *443*
Connect server: *chat.facebook.com*

Go to security settings on Facebook, create an application password. You probably have a strong password with special characters that Facebook doesn't seem to handle well. It solved my problem.

Like the link Alan provided: http://ubuntuforums.org/showthread.php?t=1683460 So credit for the link goes to him.

What worked for me was logging out in my browser and logging in with my username (as opposed to logging in with my email address which I did previously). Crazy that this works. But well, it works, so...

protected by Community May 30 '15 at 7:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.