I've bought a Cisco RVS4000 router, and have set up VPN on the box.

The only way to connect to it seems to be through a client called QuickVPN, which Cisco only releases for windows. I've successfully set up the VPN tunnel on my windows partition, but would like to make it work on my Ubuntu partition as well.

I've tried to install the QuickVPN client through WINE, and when I run it, it seems to be connecting. BUT... after a little while, the client says "The remote gateway is not responding. Do you want to wait?". If I click yes, it comes back after a little while, and if I click no, it disconnects.

If I ping any known ip on the other side of the tunnel while connected, I get no answers. I were thinking it might need some more privileges to create an interface or something like that, but I don't have any experience with WINE, and know that you should never run WINE as root or sudo it.

I've also found out that QuickVPN uses some kind of IPSEC, but that it apparently does something non-standard/proprietary, and therefore is not compatible with the IPSEC stack.

I'm all open for suggestions? :)


Some cursory web searching shows that IPSEC uses port 500. If indeed the client is trying to listen on port 500, you may run into issues because on Linux system you need elevated privileges to listen on ports <1024.

  • I think this might be an issue as well. Does anyone know how to allow a wine application to listen on ports below 1024? – LasseValentini Dec 28 '10 at 13:07
  • I've been wondering that myself...you might have better luck asking in a separate question. – Scott Ritchie Jan 8 '11 at 21:13

I managed to setup a VPN connection from a 14.04 box to a Cisco-rebranded Linksys Small Business VPN router whose default client software is QuickVPN.

The software used was the Shrew Soft VPN Client. It is available on the default Ubuntu repositories. (It's open source)

This guide worked like a charm:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.