I recently got a Dell Inspiron Special Edition 7720 computer. I am trying to install Ubuntu along side Windows. When I use the WUBI installer, the installation of Ubuntu works as long as I do not boot into Windows; if I boot into Windows, when I go back into Ubuntu, I am given a variety of error messages which claim to have corrupt or missing kernel/root directory, etc. I have been working with this problem for about a week, and have reinstalled Ubuntu MANY times. So far, I have eliminated all of the following problems: Corrupt WUBI installation (Downloaded multiple times, used on other systems), I have tried using a CD and a flash drive, both of which work on other computers. I know that no program within Ubuntu is creating the problem. I know that others have successfully installed Ubuntu on a computer with my operating system (Windows 7 SP1).

This is a much shortened version of the original question, which has been up for about 5 days, and included a more detailed description of the problem, but left everyone clueless as to the source of this problem. When I spoke with the Dell service technician who came over today to replace my keyboard, he suggested that the driver for my HDD was so new that it was not compatible with the current version of Ubuntu. His reasoning is as follows:

1) During an install from a flash drive or CD, where I am supposed to get the option to wipe my system or create a dual boot, I get a window that asks me to select a hard drive partition, but none are listed.
2) This model of computer was made public in June of this year, while Ubuntu was released in April

Adopting this theory, it would seem to me that the WUBI install fails after booting into Windows because Ubuntu can no longer find the files that it needs to load.

Does this theory seem at all plausible to anyone? I just want to install Ubuntu and have it stay on my computer. I don't care how I put it there, I just need it to work, so I would TRULY appreciate any advice or suggestions anyone could give.

Thanks so much for your time and support!!!

  • 2
    (1) can you shorten your question to include the absolute minimum describing your problem, (2) did you try running a live-CD? Then you can see from there if it detects your harddrive, and if it does you can probably exclude any non-supported harddrive theories. – steabert Aug 27 '12 at 15:11

WUBI installs Ubuntu within a Windows partition, and it is quite apparent that Windows break your Ubuntu installation. In a regular installation, Ubuntu will get its own partition, and the chances of Windows breaking something are much smaller.

First, download the ISO image of the Ubuntu CD and burn it on a CD. Then, you can use Windows to shrink the Windows partition, and finally tell Ubuntu to install itself in the remaining free space.

If you still want to install the WUBI variant, though, you will need to provide more details:

  • what is the model of your laptop?
  • what are, exactly, the error messages?
| improve this answer | |
  • It doesn't make a difference to me how I install, as long as it stays on my computer for more than one 45 minute session... I am on a Dell Inspiron 7720 (pretty new model). I did download the ISO, and put it on a flash drive. This is what I used to install on the desktop computer. It worked very well. I tried to use it on the laptop, but when I got to the point where I typically would have been notified of the presence of windows, and given the option to create a dual boot, or to wipe the system completely, or other, I got a strange dialog box. I have a pic of it. Can I share that? – Casey Hungler Aug 21 '12 at 18:03
  • And, unfortunately, I don't have the exact wording of the error messages. They change slightly each time, and I didn't write them down. I can reinstall and try to get them again, I'm sure that I won't have much trouble with that... – Casey Hungler Aug 21 '12 at 18:08
  • I edited the question with the only actual error message that I managed to capture. It popped up on screen this morning, in the last successful reboot. It said "ExecutablePath /usr/share/apport/apport-gtk." I'm not entirely sure whether that was the original error message, or an error message about the error message crashing, which it did... – Casey Hungler Aug 21 '12 at 18:32
  • Oh, about the weird window. It's called Installation Type, and includes a large info box with the headings Device, Type, Mount point, Format? Size, and Used, and includes the buttons New Partition Table..., Add..., Change..., Delete, and Revert. There is also a dropdown box titled "Device for boot loader installation:" It has only one option: /dev/sdb Nothing on the form is enabled except the install, back, and quit buttons on the bottom, so I can't get past it. I did try creating a 30 GB partition for Ubuntu, and then redoing the installer, but it didn't change anything. – Casey Hungler Aug 21 '12 at 19:11
  • Hm, what happens if you click on /dev/sdb? /dev/sdb signifies the whole disk, a partition on that disk should be something like /dev/sdb1. I do not remember the installer (I'm fan of Thinkpads, they usually work OOTB), but maybe the you will see the partitions there. The weird window you are referring to is, I think, the option for custom partitioning (strange that it doesn't give you the regular options of a standard install...). – January Aug 21 '12 at 19:27

Well, I finally seem to have found the solution; through all of the comments and suggestions made here, as well as many other outside conversations, I narrowed down the source of the problem to be with the hard drive. Eventually, I found a post that suggested that dmraid was keeping the installer from recognizing the operating system. By removing this, I was able to install Ubuntu on my laptop, though Windows now boots significantly slower.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.