3

Some days ago after partial upgrade and update my "Ubuntu 12.04 64bit" wireless disappeared.

I googled and tried several solutions such as:

1.BIOS Reset

2.Re-installing all packages related to wireless via Synaptic.

3.Re-installing bcmwl-kernel-source.

4.Running this command via terminal sudo rfkill unblock all.

But none have any effect. Now with rfkill list all I can see that:

soft block=0
hard block=0

In section Wireless LAN, so it is ok. In additional drivers section I see disabled Broadcom STA Wireless driver, and try enable it, but it gives error with long log in file /var/log/jockey.log

Important fact: My hardware is OK as I have tried to use WiFi via LiveCD and it worked. So the problem is in my Ubuntu 12.04.

But what else can I do? Wireless option has just disappeared from network window. Fn+F3 doesn't do anything, the wireless light is always turned OFF.

When I write ifconfig in terminal, it doesn't show Wlan as it showed before. It gives this code:

$ ifconfig

bnep0     Link encap:Ethernet  HWaddr 90:00:4e:12:2a:24  
          inet addr:192.168.44.88  Bcast:192.168.44.255  Mask:255.255.255.0
          inet6 addr: fe80::9200:4eff:fe12:2a24/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:23059 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20570 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:18550526 (18.5 MB)  TX bytes:3535892 (3.5 MB)

eth0      Link encap:Ethernet  HWaddr 88:ae:1d:63:30:2d  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:12685 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12685 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:982631 (982.6 KB)  TX bytes:982631 (982.6 KB)

iwconfig gives this:

bnep0     no wireless extensions.
eth0      no wireless extensions.
lo        no wireless extensions.
  • Post the output of lspci | grep -i wireless. – green Aug 21 '12 at 16:15
  • Hey green7. Its output is none. Nothing. – Elvin Haci Aug 21 '12 at 17:06
1

You can find everything about troubleshooting the wireless connections at this wiki page.

If nothing helps, reinstall Ubuntu.

  • Unfortunatelly nothing helps. I didn't want reinstall as it is long process. But it seems there is no other way. I think my problem is related with Linux Kernel. – Elvin Haci Aug 22 '12 at 5:32
  • 1
    In that case, I think it's better to reinstall than playing around with kernel versions, just to save time. – green Aug 22 '12 at 7:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.