5

I run ubuntu 10.04 with the latest version of LibreOffice (the one release the other day). When downloading a document - like something in excel in my firefox, and want to open it, it opens up in read-only mode.

I have to save the document first on my computer, then open it up to get the normal document, to be able to edit it.

I would like just to open up the download document, edit it and then store it. Not download it, store it, and then edit it, while then I have to shave it again.

Is there only a setting wrong?

Any help appreciated

3
  • 1
    Right off hand, this sounds like a feature request for LibreOffice devs. You are probably not able to make edits because the file is initially opened from a remote internet server, where you don't have write permission. That would be a convenient and sensible feature though.
    – matt davis
    Aug 21, 2012 at 14:02
  • This is the expected behaviour when selecting "open with" in the download dialog (and in general this is sensible behaviour - eg, when opening a PDF file I usually just want to read it once rather than create a persistent copy). Selecting "Save File" instead, and then opening the file from the "Downloads" window should result in an editable file.
    – chronitis
    Aug 21, 2012 at 15:00
  • @chronitis why should there be a writable copy of the file on disk before you're allowed to make changes in memory? File->New doesn't work that way.
    – OJW
    Jan 3, 2013 at 15:54

5 Answers 5

2

It looks as though Firefox saves the file to the /temp directory as readonly so that users cannot accidentally save a file opened from the browser into the temp directory, edit the file and later lose any edits. I do not see any setting within the the security sections of either Firefox or LibreOffice that would change this.

3
  • I am not sure, It have to - now I have to save them and then can edit the document. In office 2007 it is read-only as well, but can edit the document in the read-only mode. But in LibreOffice it isn't possible.
    – Tim Botha
    Aug 22, 2012 at 8:14
  • 1
    I'm not sure how Office 2007 works on Windows does it. I am unable to test that functionality. Another option within Libre Office is to hit the Edit Document button that is to the left of the create PDF button on my system. it eventually gives you an editable document - without saving.
    – Stephen
    Aug 22, 2012 at 17:38
  • Stephen, Also when I receive an email that has an attachment, I have the read-only problem. I can't even open up an email attachment, directly edit it and then save it, I have to save it, edit and re-save. In Word and Window 7 I don't have to do it - I can edit read-only docs, then save them.
    – Tim Botha
    Aug 23, 2012 at 13:50
2

Workaround: In your Firefox about:config, create a new preference called browser.helperApps.deleteTempFileOnExit (type: boolean) and set it to false. You can create a new preference by right-clicking and selecting "New" from the context menu.

This configuration setting will make downloaded temporary files writeable again. Unfortunately, it will also keep a copy of those temporary files lying around (it won't delete them when Firefox closes), but oh well, what can you do.

References:

1

In the first row of icons, the fifth button (looks like paper with a pencil on it), hover and it will say Edit File. It enables edit mode even from read-only files. Then you should be able to save as after making your modifications

0

I have not tried this. Use at your own risk! Keep the quotes in this post do not copy!

This will point firefox to save temp files in an other directory, Maybe this could solve your problem if that directory is writeable by you.

  1. open "about:config" in firefox, click through the warning

  2. Right-Click into the list and select "New->String"

  3. Enter "browser.cache.disk.parent_directory" as the new Key

  4. Enter some directory that exists and is read-/writeable for you and the firefox process e.g. /home/yourUserName/Temp

Good Luck.

FYI: This is part of a "Move your logs and temp files to RAM" article I found here: http://www.fewt.com/2010/07/move-your-logs-and-temp-files-to-ram.html

0

There are many wrong answers on the Internet about this problem. Try this:

From the menu, select Format | Sections...

Select each section and ensure that, under Write Protection, the Protected checkbox is not selected. (You can use multiple-select to do this to all sections at once.)

1
  • Welcome to askubuntu! Thank you for trying to help! As 10.04 is no longer supported IMHO your efforts would be more appreciated by the community here
    – Elder Geek
    Dec 19, 2016 at 22:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.