I am a Linux newbie, and this is the first time I am using TOR in 12.04. I have an issue in running TOR for which I couldn't find any specific answer in the Internet.

So let me explain.

  1. I downloaded TOR browser bundle (tor-browser-gnu-linux-x86_64-2.2.38-1-dev-en-US.tar.gz) and saved to this location: /media/50B8245BB82441B8/TOR/

  2. I then extracted tar.gz file into the same directory. So now I have /media/50B8245BB82441B8/TOR/tor-browser_en-US

In this directory, there is a file start-tor-browser. The problem is that, when I double click this file, it opens in text format, instead of launching TOR Vidalia.

So I right-clicked this file > Permissions > checked Allow executing file as program, but again it automatically unchecks it.

I then thought of executing this file through the terminal, but nothing seems to work.

cd /media/50B8245BB82441B8/TOR/tor-browser_en-US    
jerry@ubuntu:/media/50B8245BB82441B8/TOR/tor-browser_en-US$ start-tor-browser    
start-tor-browser: command not found    
jerry@ubuntu:/media/50B8245BB82441B8/TOR/tor-browser_en-US$ cd start-tor-browser    
bash: cd: start-tor-browser: Not a directory    
jerry@ubuntu:/media/50B8245BB82441B8/TOR/tor-browser_en-US$ sudo start-tor-browser    
[sudo] password for jerry:     
sudo: start-tor-browser: command not found    
jerry@ubuntu:/media/50B8245BB82441B8/TOR/tor-browser_en-US$ gksu start-tor-browser    

As you can see, when I use gksu, nothing really happens except an empty command line added with a blinking cursor.

Can someone please help?

  • 2
    out of curiosity what architecture is your computer? EDIT: Also, I'm not sure but I believe to run something you need to place a "./" before it. – KI4JGT Aug 21 '12 at 6:48
  • AMD Athlon 64 X2 Dual Core Processor 5000+, 2GB RAM – Jerry-bliss Aug 21 '12 at 7:16
  • Do what damien has stated above and then try the 32 bit version of the TBB if his suggestion doesn't work. I'm also running a 64bit machine but whenever I try to download Tor it defaultly gives me the 32bit version of the program. – KI4JGT Aug 21 '12 at 7:21
  • I tried, it did not work and here is the error message. Launching Tor Browser Bundle for Linux in /home/gpsvn/Desktop/tor-browser_en-US start-tor-browser: 228: start-tor-browser: ./App/vidalia: Permission denied Vidalia exited abnormally. Exit code: 126 – user149013 Apr 13 '13 at 10:03
  • @Jerry-bliss /media/50B8245BB82441B8/ is a USB key right? Could you try from your hdd. Your problem might be related to this Q&A – danjjl Apr 13 '13 at 10:12

It seems that the device you have extracted it on does not support permissions (is not a native Linux filesystem). Re-extract the tar.gz but do it in your home directory (home directory should support permissions).


| improve this answer | |
  • 2
    Yes this is a common problem. It wasn't being executed because OP was trying to execute it from external media. Try running it after extracting it to your Desktop. – Sheharyar Jun 16 '13 at 21:40
  • If you just copy it, the "new" permissions - not executable - will be copied and it still won't work. – user92200 Jun 25 '13 at 7:27
  • I had this same problem and fixed it in the same way, but I have to wonder: why won't it work from external media? If its a permissions thing, if my external drive was formatted as ext4 would it work? – ohnoplus Aug 17 '14 at 17:52
  • Yes. FAT does not use permissions and is the most likely choice for an external drive. Linux native filesystems work, ext{2,3,4} are included. – user92200 Aug 18 '14 at 14:22
  • In my case that was caused by extracting through online archiver. Extracted through Ubuntu's default and voila – janot May 17 '15 at 17:16

I had the same issue. No matter what I did the start-tor-browser file would always open as text.

Here's the fix (in Ubuntu Desktop 13.04):

  1. Open directory "tor-browser_en-US" in file manager window, navigate to the top menu bar of your screen and click on "Files".
  2. Click on "Preferences", select the "behavior" tab, and change setting to "Run executable text files when they are opened".

The default setting is to "View executable text files when they are opened" and that is why it opens as text file.

| improve this answer | |

All you have to do is double click the start-tor-browser file and click run when prompted and it will start. It obviously needs to be executable.Maybe root owns directory change ownership sudo chown -R <username>:<groupname> path/to/tor-directory Make executable cd path/to/tor-directory chmod +x start-tor-browser double click on start-tor-browser click run and it should start up.

| improve this answer | |
  • When i dblclick start-tor-browser file, it immediately opens the textfile content without any prompting. And what is <groupname>? Should it be ubuntu? – Jerry-bliss Aug 21 '12 at 8:11
  • 1
    This would be because its not executable you said it wouldn't stay clicked on when you tried to change permissions which made me believe root owned the directory . What you originally tried would work if you gksu nautilus go to tor directory and changed to executable. you could also change the owner and group to jerry whilst there or how i originally said replacing <username>:<groupname> for jerry:jerry – damien Aug 21 '12 at 8:34
  • thanks, but still doesn't seem to work.... jerry@ubuntu:/media/50B8245BB82441B8/TOR/tor-browser_en-US$ sudo chown -R jerry:jerry /media/50B8245BB82441B8/TOR/tor-browser_en-US [sudo] password for jerry: jerry@ubuntu:/media/50B8245BB82441B8/TOR/tor-browser_en-US$ cd /media/50B8245BB82441B8/TOR/tor-browser_en-US chmod +x start-tor-browser ....... Nothing happens after that – Jerry-bliss Aug 21 '12 at 10:33
  • Screenshot: mediafire.com/conv/… – Jerry-bliss Aug 21 '12 at 11:23
  • Hi jerry i thought it may be because it appears you have TOR on another partition or usb that could be causing the issue.However i was still able to change owners and permissions placing it on another partition on my system.How is that drive formated? Try copying the tor-browser_en-US directory and place it in your home or downloads folder instead of another partision. Then try changing permission again from there and see if it then works. – damien Aug 22 '12 at 1:13

It's harder, because, in Ubuntu 12.04, it seems that unity does not allow the execution of the start-tor script. I've found a solution modifying what was suggested here: http://www.scribd.com/doc/85715850/How-to-Install-and-Configure-Tor-on-Ubuntu-11

These are the steps: download tor, browse bundle and extract wherever you want, let say in your home direcory that is: /mypc/myhome/

Then open gedit and write in a new file this code:

[Desktop Entry]
Comment=Browse the internet Anonymously
Exec=/mypc/myhome/tor-browser_en-US/start-tor-browser %U

save the file with the name Vidalia.desktop

in a terminal input

gksudo nautilus

so you have a file browser with the privilege of administrator, now copy the Vidalia.desktop file in


Close nautilus and now in your Unity application window you will have an icon with the name Vidalia, click on it and you will have you TorBrowser

| improve this answer | |
  • You don't need root! You own your ${HOME}!!! – user92200 Aug 18 '14 at 14:23

In my case my partition was mounted with noexec option set on the drive.
Check this by running mount.

/more/drive/info with /stuff/that/doesn't apply here....
/dev/sdb5 on /home type ext3 (rw,noexec,nosuid,nodev) 

Yours might differ a bit but you are looking for your device.

if you see the "noexec" option on your partition like this one then this solution applies to you too.

Remount your drive (if you are not root use sudo):

sudo mount -o remount,exec -t ext3 /dev/sdb5 /home

Replace the specific details like so:

 sudo mount -o remount,exec -t [your_drive_format] [/dev/partition#] [/mount/point]

Try again to launch tor...

isme@CloudAtlas:~/Software/tor-browser_en-US# ./start-tor-browser.desktop 
Launching './Browser/start-tor-browser --detach'...

Ok, so it works... what now?!?
You will have to change your /etc/fstab file to remount with exec option set.

sudo gedit /etc/fstab

You will see some entry relating to the partition you want to set the option on. You will see a list that may include default,rw,user,noexec,nosuid,...etc... a full list of options can be found @ https://help.ubuntu.com/community/Fstab/ Just add the exec option to your fstab options for that partition (if noexec is there then remove it) and you should be good to go.

| improve this answer | |

What I did was just open up the terminal and drag the file start-tor-browser into it and it started up from there.

| improve this answer | |

I had the same problem and it was the executable permission. (specially that you said it gets unchecked.) use the following command to add the executable permission:

chmod +x start-tor-browser

Also if that didn't work change the directory to somewhere in your ~ directory. (i.e. your user's home directory)

I hope this helps since it fixed my problem. In addition I suggest adding it to your bin folder so you can execute it easier:

ln -s {location of start-tor-browser file} /usr/bin/tor

Then you can run it by just typing the following in your terminal tor

Good luck!

| improve this answer | |

Navigate to the top menu bar of your screen and click on Files.

Click on Preferences → select the behavior tab → change setting to "Run executable text files when they are opened"

The default setting is to "View executable text files when they are opened" and that is why it opens as text file.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.