Possible Duplicate:
How to Install Broadcom / STA Wireless card (BCM43XX)

I used this package to install the driver on 3.2 Kernel and it was working perfectly.

Unfortunately the system used to freeze randomly with 3.2 kernel so I installed 3.4 kernel, now there is no freezing, the only problem is that my wifi card is not working, I tried to re-install the package, but didn't work.

I can see the driver in the "additional drivers" and it say that it is active, but when I execute iwconfig it doesn't show up. I've even tried ndiswraper and that didn't work either.

my lspci:

01:00.0 Network controller: Broadcom Corporation Device 4365 (rev 01)

2 Answers 2


Updated, some additional fixes, and kernels 3.6.x now also supported


You may also want to look at notes and changelog here:


If you have problem loading this module under stock Ubuntu 12.04 kernel 3.2.x there might be problem with installed backported modules. In my case it's linux-backports-modules-cw-3.4-3.2.0-* containing cfg80211 and lib80211 modules which conficts with stock kernel ones. I need this package because it contains alx driver for my ethernet network adapter. If you try to modprobe wl it tends to load dependencies from backported cfg80211 and lib80211 drivers and fails to load with FATAL: Error inserting wl (/lib/modules/3.2.0-34-generic/updates/dkms/wl.ko): Invalid argument

I've solved it by creating modprobe configuration /etc/modprobe.d/wl.conf which forces loading of stock kernel modules

install cfg80211 /sbin/insmod /lib/modules/`/bin/uname -r`/kernel/net/wireless/cfg80211.ko
install lib80211 /sbin/insmod /lib/modules/`/bin/uname -r`/kernel/net/wireless/lib80211.ko
  • Hey Jasmine, thanks for the work. I installed the driver, and it does appear in the 'additional drivers' section in Software Sources, but the applet doesn't show a wireless section, 'iwconfig' gives 'no wireless extensions.' and 'lshw' gives '*-network UNCLAIMED' for my wireless :( any clue?
    – Koen
    Oct 19, 2012 at 20:33
  • I believe you need to reboot after first install. Then, make sure wl module is loaded lsmod | grep ^wl ifconfig -a you should see a new "ethX" interface The next update I'm working on renames the ethX to wlanX Currently working on fix for 3.6 kernel as well. Oct 20, 2012 at 13:28
  • hmm. I'm fearing there's something fundamentally wrong my system. 'lsmod | grep ^wl ifconfig -a' gives 'grep: ifconfig: No such file or directory', sudo makes no difference. (I rebooted several times in the meantime)
    – Koen
    Oct 20, 2012 at 13:48
  • 1
    Sorry. Everything got wrapped. no matter what I do, lines get wrapped in comments. lsmod | grep ^wl If the above command returns nothing, then wl module isn't loaded. Which is weird, because it should be automatically loaded. Regardless, to load the module if it wasn't already loaded: sudo modprobe wl Now, you should have a new ethX interface (in the next update, this is renamed to wlanX) /sbin/ifconfig -a and /sbin/iwconfig N.B.: please wait for coming, cleaner, update. And 3.6 kernel is supported ;) Oct 21, 2012 at 5:11
  • sigh. I get FATAL: Module wl not found. Should I follow these instructions: wiki.debian.org/wl? (if so: squeeze or wheezy?)
    – Koen
    Oct 21, 2012 at 12:29

I had the same problem after upgrading to kernel 3.5.0 and found the solution in the following thread: http://www.spinics.net/lists/linux-wireless/msg97247.html

After installing the mentioned package (http://jas.gemnetworks.com/debian/wireless-bcm43142-dkms- the wireless started working again.

  • Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Peachy
    Oct 2, 2012 at 15:47

Not the answer you're looking for? Browse other questions tagged .