0

I tried to install wine. Since it was taking more than an hour I restarted the system.

I found the following error when I tried to open synaptic package manager.

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 
E: _cache->open() failed, please report.

Due to this error I could not open synaptic manager. Hence I could not even add anything to repositories.

I have to install many other softwares and I am stuck now.

how to solve this? please help

1
  • Post the output of sudo apt-get update
    – karthick87
    Dec 17, 2010 at 3:06

3 Answers 3

4

The error message gives you the solution:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a'
to correct the problem.

In order to do this, open a terminal window (you can find that in Applications->Accessories on a stock Ubuntu install) and copy and paste the sudo command:

sudo dpkg --configure -a

This will instruct the package manager to finish what it was doing when it was last running and was interrupted.

This can happen, for example, if the power is cut or the package manager died due to some problem with the computer (I/O errors on hard disks, or bad memory, or bad swap due to the I/O errors on hard disks, or any number of other but rare problems).

2
  • thanks but when I tried this in terminal its showing... Connecting to nchc.dl.sourceforge.net|2001:e10:ffff:1f02::17|:80... failed: Network is unreachable. --2010-12-17 13:37:15-- ufpr.dl.sourceforge.net/sourceforge/corefonts/arialb32.exe Resolving ufpr.dl.sourceforge.net... 200.17.202.1 Connecting to ufpr.dl.sourceforge.net|200.17.202.1|:80
    – nitzsi
    Dec 17, 2010 at 2:29
  • Does the system have a network connection? Dec 17, 2010 at 3:49
0

Did you try running sudo dpkg --configure -a as the error message says?
Applications -> Accessories -> Terminal, type sudo dpkg --configure -a and hit Enter.

1
  • I tried this.. but it is showing Connecting to nchc.dl.sourceforge.net|2001:e10:ffff:1f02::17|:80... failed: Network is unreachable. --2010-12-17 13:37:15-- ufpr.dl.sourceforge.net/sourceforge/corefonts/arialb32.exe Resolving ufpr.dl.sourceforge.net... 200.17.202.1 Connecting to ufpr.dl.sourceforge.net|200.17.202.1|:80.
    – nitzsi
    Dec 17, 2010 at 2:26
0

Try this:

  • Go to Start-button -> Preferences -> Software & Updates

  • Choose the tab Other Software and remove the sources that do give errors. ( ufpr.dl.sourceforge.net )

Later you can reconfigure using dpkg or sudo aptitude.

It's tested and works fine with me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy