As of today, this was fixed by the latest nvidia-current update :)

Until last week i had a working bumblee/nvidia set up.

Now, when i do

optirun -vv firefox

I'm greeted by:

[ 6174.504548] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 6174.632794] [DEBUG]optirun version 3.0.1 starting...
[ 6174.632850] [DEBUG]Active configuration:
[ 6174.632861] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 6174.632872] [DEBUG] X display: :8
[ 6174.632883] [DEBUG] LD_LIBRARY_PATH: 
[ 6174.632893] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 6174.632902] [DEBUG] VGL Compression: proxy
[ 6174.737261] [INFO]Response: No - error: Could not load GPU driver

[ 6174.737309] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 6174.737329] [DEBUG]Socket closed.
[ 6174.737365] [ERROR]Aborting because fallback start is disabled.
[ 6174.737379] [DEBUG]Killing all remaining processes.

dpkg -l | grep nvidia
ii  bumblebee-nvidia                       3.0.1-1~preciseppa1                     nVidia Optimus support using the proprietary NVIDIA driver
ii  nvidia-common                          1:0.2.44                                Find obsolete NVIDIA drivers
ii  nvidia-current                         304.37-0ubuntu1~precise~xup1            NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-current-updates                 295.49-0ubuntu0.2                       NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-settings                        302.17-0ubuntu1~precise~xup3            Tool of configuring the NVIDIA graphics driver
ii  nvidia-settings-updates                295.33-0ubuntu1                         Tool of configuring the NVIDIA graphics driver

I've seen some comments to the effect of deleting


but doing

ls /usr/share/X11/xorg.conf.d/


10-evdev.conf         11-evdev-trackpoint.conf  50-vmmouse.conf  51-synaptics-quirks.conf
11-evdev-quirks.conf  50-synaptics.conf         50-wacom.conf

Is there a way to fix this?


same problem. Renaming the drivers name solved the problem but

  • I can't access external monitors (I could just before last update). I don't see them from the "displays" system setting
  • Running optirun -vv nvidia-settings rise the error that I'm not currently using nvidia X drivers and that I shoud run nvidia-xconfig. the -vv doesn't show any error, full log is reported below

    optirun -vv nvidia-settings
    [  674.856470] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
    [  674.856716] [INFO]Configured driver: nvidia
    [  675.044903] [DEBUG]optirun version 3.0.1 starting...
    [  675.044922] [DEBUG]Active configuration:
    [  675.044925] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
    [  675.044928] [DEBUG] X display: :8
    [  675.044930] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-current:/usr/lib32/nvidia-current
    [  675.044933] [DEBUG] Socket path: /var/run/bumblebee.socket
    [  675.044936] [DEBUG] VGL Compression: proxy
    [  677.053609] [INFO]Response: Yes. X is active.
    [  677.053623] [INFO]Running application through vglrun.
    [  677.053851] [DEBUG]Process vglrun started, PID 4605.


Solved installing nvidia-current-updates

  • 1
    Thanks, but nvidia-current-updates is already installed on my machine. – user2413 Aug 21 '12 at 12:57
  • 1
    "Solved by [...]"? – erikbwork Jun 15 '15 at 18:03

This is copied from github user ArchangeGabriel:

For your current issue, the fact is that the nvidia kernel module and driver have changed their name on Ubuntu in this new 304.22 version. So you have to edit (with sudo rights) /etc/bumblebee/bumblebee.conf and do the two followings things :

  1. Replace Driver= by Driver=nvidia
  2. Replace KernelDriver=nvidia-current by KernelDriver=nvidia

Then reboot, and you should be fine for optirun.

//end quote.

So the answer suggested of editing KernelDriver is correct, but needs 1 extra step due to the name change. In likelihood you probably have nouveau kicking around somewhere on your system which is overriding the nvidia driver when bumblebee goes to autodetect (if Driver= is left blank it tries to autodetect with nouveau winning out where you actually want nvidia).

I had the same problem as you, tried this more-complete answer and now bumblebee / optirun work just fine. Hope it works for you, too.

  • didn't solve the issue, but the error message is somewhat different now. I have "[DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-current:/usr/lib32/nvidia-current" (i.e. twice the same string separated by ':') where i had "[DEBUG] LD_LIBRARY_PATH: " ie blanks. – user2413 Aug 21 '12 at 13:07

@Bobjohnson thank you!

It worked for me (nvidia gforce 610m and Linux mint 13)

i just did

  • sudo nano /etc/bumblebee/bumblebee.conf
  • Replace the line Driver=by Driver=nvidia
  • Replace the line KernelDriver=nvidia-current by KernelDriver=nvidia
  • Then save, reboot and check with optirun glxgears
  • I have this problem to , like others. I changed the phrases to Driver=nvidia and KernelDriver=nvidia , but it returns : /usr/bin/vglrun: 296: exec: glxgears: not found There should be a way to drive geforce on laptops. – mohammads Aug 23 '12 at 13:58
  • @Mohammad I know I'm a bit late here, but that looks like glxgears is nonexistent, possibly because the mesa-utils package is not installed. Try glxspheres, which comes with the virtualgl package. – Darael May 5 '13 at 10:55

I had this problem too. It seems that nvidia module was renamed from nvidia-current to nvidia after recent updates. You need to edit file /etc/bumblebee/bumblebee.conf and change line:




Then restart computer or bumblebee, and optirun should work again.

I hope it helps. I have made few other changes, before it start working, so query if it didn't work...

  • thanks for the quick reply. There must be more to it, because i still get the same error :~ – user2413 Aug 20 '12 at 12:23
  • try getting rid of nvidia-settings-updates and nvidia-current-updates, and probably reinstall nvidia-current. I don't have these two packages. – marqsbla Aug 20 '12 at 13:35
  • ok, but before i try that: what graphic card do you have? – user2413 Aug 20 '12 at 14:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.