I have been using Ubuntu since 9.10 and have always gamed in wine without an issue. I have been running 12.04 since its release and have been playing the Sims3 and Wow in Ubuntu flawlessly. However I recently upgraded my video card from a Radeon HD 6850 to a HD7870, when I did the upgrade I reformatted and reinstalled Ubuntu 12.04 with the version of fglrx available through jockey. Now when I run games in wine they still play OK and 90% of the graphics are there, but not all. For example in the Sims3 everything renders just fine except the trees, they render as green cubes with the texture displaying as a flat image protruding from the center. There is a screen shot below.

enter image description here

Wow isn't any better, flags and banners in the game just display as large textured rectangles, however Wow is so bad it wont even load completely into the game, but the errors are evident on the character select screen.

I am not sure what to do, I had both of these games running fine with the same fglrx version just a few weeks ago, and now they do not work properly. I know its not a hardware issue seeing how all these games run flawlessly in windows, If I can get 50-60 FPS in BF3 on Ultra, then I think the card is OK.

I attempted to install the (Post release updates) version of fglrx but it fails every time (seems to be a know issue, so its not just me.) I installed "fglrx-updates" and the corresponding amdcccle package through synaptic, and it broke my system, so I had to remove them and revert back to the open source driver. Lastly I attempted to install the latest driver from the AMD website, it installed with no errors however once I restarted I was still using the open source driver and the catalyst control center was nowhere to be found even though the software center claimed that it was installed.

I am out of ideas, any help would be very appreciated. Thank you.


Problem solved. I tried for a second time to follow the guide here and this time it worked. I'm now at Catalyst 12.8 and everything is running just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.