5

I am on an HP Envy 14, and the proper resolution that I should be using is 1366x768. This is not an option and I am stuck on 1024x768. I am using Linux 12.04.

lspci | grep VGA:

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Madison [Radeon HD 5000M Series]

I've tried to add the resolution as a mode in xorg.conf but that does not work. Please any help would be appreciated. I'm new to Linux and just got my dual boot working but this resolution issue is killing me.

I just tried using the xrandr command:

xrandr --newmode "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync

But I get an error:

xrandr: Failed to get size of gamma for output default

lsmod returns the following:

Module                  Size  Used by
vesafb                 13844  1 
rfcomm                 47604  12 
bnep                   18281  2 
parport_pc             32866  0 
ppdev                  17113  0 
snd_hda_codec_hdmi     32474  1 
arc4                   12529  2 
joydev                 17693  0 
hid_logitech_dj        18594  0 
i915                  472941  5 
uvcvideo               72627  0 
usbhid                 47199  1 hid_logitech_dj
hid                    99559  2 hid_logitech_dj,usbhid
psmouse                87692  0 
iwlwifi               332525  0 
mac80211              506816  1 iwlwifi
videodev               98259  1 uvcvideo
snd_hda_codec_idt      70795  1 
mei                    41616  0 
btusb                  18288  2 
v4l2_compat_ioctl32    17128  1 videodev
hp_accel               25976  0 
lis3lv02d              19876  1 hp_accel
hp_wmi                 18092  0 
sparse_keymap          13890  1 hp_wmi
input_polldev          13896  1 lis3lv02d
drm_kms_helper         46978  1 i915
drm                   242038  2 i915,drm_kms_helper
i2c_algo_bit           13423  1 i915
serio_raw              13211  0 
snd_hda_intel          33773  5 
snd_hda_codec         127706  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
snd_hwdep              13668  1 snd_hda_codec
bluetooth             180104  23 rfcomm,bnep,btusb
cfg80211              205544  2 iwlwifi,mac80211
snd_pcm                97188  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
mac_hid                13253  0 
snd_seq_midi           13324  0 
snd_rawmidi            30748  1 snd_seq_midi
snd_seq_midi_event     14899  1 snd_seq_midi
snd_seq                61896  2 snd_seq_midi,snd_seq_midi_event
fglrx                3263886  0 
snd_timer              29990  2 snd_pcm,snd_seq
snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    78855  20         snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_ra    wmidi,snd_seq,snd_timer,snd_seq_device
wmi                    19256  1 hp_wmi
video                  19596  1 i915
intel_ips              18174  0 
soundcore              15091  1 snd
snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
lp                     17799  0 
parport                46562  3 parport_pc,ppdev,lp
r8169                  62099  0 

I have installed ATI/AMD proprietary FGLRX graphics driver. But there is another one called ATI/AMD proprietary FGLRX graphics driver (post-release updates) which I have trouble installing because it gives me an error and tells me to look at some sort of jockey log.

11
  • Can you please post the output of lsmod? And tell us what, if any, proprietary drivers you activated in Jockey (Additional Drivers) or otherwise? Aug 20, 2012 at 4:16
  • I have posted the output of lsmod and mentioned: I have installed ATI/AMD proprietary FGLRX graphics driver. But there is another one called ATI/AMD proprietary FGLRX graphics driver (post-release updates) which I have trouble installing because it gives me an error and tells me to look at some sort of jockey log.
    – Megan
    Aug 20, 2012 at 4:26
  • Well it's using the kernel module for the Intel card (i915), I'm not really familiar enough with ATI cards to know how you would switch to using the ATI card but a) the intel driver should support the native resolution one would think, and b) /var/log/jockey.log is the jockey log it is telling you to look at. Aug 20, 2012 at 4:36
  • Just tried to cat /var/log/jockey.log and it is extremely long...not sure what I should be looking for :(
    – Megan
    Aug 20, 2012 at 4:41
  • Try installing the post release driver again and only look at the new lines added to the log. You could also put the entire thing here paste.ubuntu.com and link to it. Also tail is probably better than cat for checking log files (displays the last ten lines of a file by default. you can use the -n flag to set how many lines you want to display). Aug 20, 2012 at 4:43

4 Answers 4

0

Open your systems settings from top panel right corner wheel.

in your system settings look at monitor settings . there you can set your monitor resolution from available resolutions .

1
  • I am looking to make 1366x768 an available resolution, since this is the resolution that my laptop is meant to use.
    – Megan
    Aug 20, 2012 at 3:17
0

Maybe this will help

maybe this will help. Open displays from settings and adjust the resolution from drop down menu

1
  • My only options are 1024x768 and 800x600. I am looking to make 1366x768 an option.
    – Megan
    Aug 20, 2012 at 3:35
0

Try to install the same fglrx driver again. In my installation sometimes, i need to try to install the driver twice to get installed.

0

Quite late, but guess it might help someone else facing the same issue (I believe it's a quite common issue, even in later ubuntu versions - at least with nvidia).

Your lsmod only lists i915 - which points to Intel, whose max resolution is 1024x768.

Run the command: lspci -vnn | grep -i VGA -A 10 & see if it lists fglrx as Kernel driver in use. The command ubuntu-drivers list should also show you the driver currently in use.

Also check Additional Drivers tab under Software & Updates shows that it uses your radeon card & the recommended driver for it. If not, select the correct driver & restart.

You can try to install the correct driver (if not installed already), using sudo ubuntu-drivers autoinstall (assuming you have the Software restricted packages under Software & Updates enabled already).

Alternatively, search for the recommended driver for your configuration, download it & install it manually using dpkg -i <filename>.deb.

Or, still better, search for a trusted ppa repository that offers the exact driver for your Radeon card & run sudo apt-get update && sudo apt-get upgrade.

Note: To add a ppa respository to your software update list, from the command line, run sudo add-apt-repository <your_ppa_repository_name_here>.

See:

  1. What are PPAs and how do I use them?
  2. https://help.ubuntu.com/community/RadeonDriver

This way (with ppa repository addition), you'll get all the required updates automatically, whenever you run the update command.

If all the above points that the correct radeon driver has already been installed, but somehow it's using Intel card only... then, update the grub file as below:

  1. Open the grub file: sudo vi /etc/default/grub.
  2. Add the text nouveau.modeset=0 i915.modeset=0 to the line GRUB_CMDLINE_LINUX_DEFAULT. Important: Do not remove the existing text in the line. Just add the above, to the existing text. This will suppress the other drivers from being used at startup & will use the Radeon.
  3. Update the grub file using sudo update-grub. Then, restart & see if it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.