1

My Ubuntu 12.04 suddenly stopped to auto-lock after X minutes. It doesn't matter how long I leave the computer idle, it NEVER turns the screen off and never locks the screen either.

I am using Gnome-shell. Under the Brightness and Lock menu, I have marked:

  • Dim screen to save power
  • Turn screen off when idle for 5 minutes
  • Lock screen after 5 minutes

I have already re-installed gnome-screensaver (no effect). Any ideas?

  • Did you do sudo apt-get purge gnome-screensaver, and then sudo apt-get update && sudo apt-get install gnome-screensaver? – Max Tither Aug 18 '12 at 22:42
  • @cgubuntu1204, no success... purged gnome-screensaver and reinstalled it. Seems to have no effect. Still wont lock the screen. – yurividal Aug 19 '12 at 19:14
  • Did it used to work? Did you do something recently that could cause this? – Max Tither Aug 19 '12 at 19:16
  • It used to work. I have done nothing besides update-manager... Also, i have noticed that it is not related to GNOME, because even if i login on Unity interface, it still does not work – yurividal Aug 19 '12 at 19:23
1

Start the terminal with Ctrl + Alt + T, and then type:

  1. sudo apt-get install dconf-tools
  2. Start dconf-editor
  3. UnCheck(if the option check means) org->gnome->desktop->lockdown-> disable-lock-screen (for verify - goto System settings->Brightness & Lock: check the Lock option enable or not).
  4. Close the editor.
  5. Restart the system & see the changes.
0

A perhaps easier method of user1709672's response is to open terminal (Ctrl + Alt + T), and type this: sudo apt install unity-tweak-tool

Once installed, open it by locating it in your application menu of choice by searching "Unity Tweak tool" (or from terminal/Alt-F2 box by typing unity-tweak-tool). Then, click the security button (I think it defaults to look like a little castle with marbles bouncing away from it), and make sure the "Disable Screen Lock" and perhaps "Disable User Switching"/"Disable User Log Out" options are unchecked. If there's a "Disable Display Sleep" option on yours, uncheck that as well. If non are checked, perhaps try checking and unchecking each one (sometimes, when this program goes in to change the configs, it can overwrite a mistakenly changed one, and then changing it back gets you to the target config).

Restart and see if this works. Also, try manually inducing the lock window with Ctrl + Alt + L.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.