To begin, I have read both Is there a way to get a Kindle Fire to work with 12.04? and How can I transfer files to a Kindle Fire with a Micro-USB cable?

My problem is that I am unable to mount my Kindle Fire in order to add books to it. I have installed calibre, but it is unable to manage any devices until the computer itself has recognized it.

The latter post had an excellent answer (provided by @jeremiah) that was making some progress. Unfortunately, I think I don't know enough about the -t flag used with mount.

This is what I've done...

Ran dmesg to locate the device:

[    3.920886] sd 6:0:0:0: [sdb] Attached SCSI removable disk

Confirmed it's location:

$ sudo ls -l /dev/disk/by-id
lrwxrwxrwx 1 root root  9 Aug 18 15:52 usb-Amazon_Kindle_3C6C002600000001-0:0 -> ../../sdb

So we know that my Kindle is recognized on /dev/sdb. I then used the mount command suggested by @jeremiah:

$ sudo mount -t ext3 /dev/sdb/ /mnt/kindle/
mount: no medium found on /dev/sdb

The same error occurs for sudo mount /dev/sdb /mnt/kindle.

Note: I have created the 'kindle' directory in 'mnt'

Any suggestions?


The new Kindle Fires can only be managed via a protocol known as MTP, but you can still mount them.

First make sure you have mtpfs installed.

sudo apt-get install mtpfs

Then, since udev and libmtp do not yet know about Kindle Fire do :


My Kindle Fire HD shows up as "Bus xxx Device yyy: ID 1949:0007 Lab126"

What's important is the USB ID.

Next, add a file to udev to recognize your device:

sudo vi /etc/udev/rules.d/51-android.rules

Add this line to the end, substituting your USB IDs you figured out above if they are different:

SUBSYSTEM=="usb", ATTR{idVendor}=="1949", ATTR{idProduct}=="0007", MODE="0666"

Connect your Kindle and look to see if the system found it:


In the spam you should see something like this:

[32421.676671] usb 3-1: >new high-speed USB device number 4 using xhci_hcd
[32421.702240] usb 3-1: >New USB device found, idVendor=1949, idProduct=0007
[32421.702247] usb 3-1: >New USB device strings: Mfr=2, Product=3, SerialNumber=4
[32421.702250] usb 3-1: >Product: Kindle
[32421.702254] usb 3-1: >Manufacturer: Amazon
[32421.702257] usb 3-1: >SerialNumber: xxx

If you couldn't find your device with lsusb, you can get the identifiers here too, but when you edit the udev rules you'll have to disconnect and reconnect.

Now let's make a place to mount it.

sudo mkdir -p /media/Kindle
sudo chmod 755 /media/Kindle

Also, it doesn't hurt to make sure fuse is set up to allow regular users to mount things.

Make sure /etc/fuse.conf is set up for this:

sudo vi /etc/fuse.conf

Look for the line that says "user_allow_other" and make sure it is uncommented.

Almost there! This part will be automatic from now on. All we have to do is mount it now.

Plug it in and setup the MTP over USB connection by mounting it, like this:

mtpfs -o allow_other /media/Kindle

Be patient with it, it's not the fastest thing ever. At any rate, once this command completes, you should see a kindle file system in Nautilus, etc.

When you're done using it, for example I load music into /media/Kindle/Internal\ Storage/Music, or use the ebook tool Calibre,

fusermount -u /media/Kindle

I drop these commands into aliases, but you can just as easily add a "RUN=" to the udev rule or stuff them into shell scripts.

I prefer the Android app "ES File Explorer" to wander around and look at files on my Kindle... because Kindles are not good at "auto-discovery" of new files.

  • I tried your method connecting to the Kindle Fire HD, but got the following: mtpfs -o allow_other /media/Kindle Listing raw device(s) Device 0 (VID=1949 and PID=0007) is UNKNOWN. Please report this VID/PID and the device model to the libmtp development team Found 1 device(s): 1949:0007 @ bus 2, dev 8 Attempting to connect device Android device detected, assigning default bug flags Listing File Information on Device with name: (NULL) fusermount: failed to open /etc/fuse.conf: Permission denied fusermount: user has no write access to mountpoint /media/Kindle It won't mount. Any ideas?
    – N.C. Weber
    Oct 26 '12 at 19:17
  • For some reason /etc/fuse.conf is unreadable or just isn't there... did fuse get installed when you installed mtpfs? Feb 17 '13 at 22:00
  • This helped big time!! My Kindle Fire is connected to Ubuntu 12.04! However I am considering changing to Kindle Paperwhite. An obstruction to this change, as far as I am concerned is whether the same method helps in connecting my Kindle Paperwhite to Ubuntu instead! So I'd like to know whether this method holds good for Paperwhite.
    – Karthik C
    Apr 21 '13 at 6:22

I have found a very simple solution to the Kindle Fire HD problem. Open Synaptic or the Ubuntu Software Center (whatever your preference) and install gMTP. This is a program designed to interface with MTP file system devices like the old Creative Zen MP3 players. It also works perfectly with the new Kindle Fire HD. You can view the entire storage area on the Kindle Fire HD, upload, download, and delete files. Give it a try!

  • This is nice! It worked with my Kindle Fire! Cheers! Will it work with Kindle Paperwhite too?
    – Karthik C
    Apr 21 '13 at 12:46

Just installing gMTP didn't help me. I had to install libmtp. For step by step instructions, visit, Hooking up a Kindle Fire HD with Ubuntu 12.10 - http://xchamitha.blogspot.co.uk/2012/11/hooking-up-kindle-fire-hd-with-ubuntu.html

  • Link doesn't exist (anymore)
    – Jason
    Apr 21 '15 at 1:12

I tried and I just removed ext3 from the

sudo mount -t ext3 /dev/sdb/ /mnt/kindle/

to this:

sudo mount /dev/sdb/ /mnt/kindle

You can try using gMTP. You may also need to install libmtp.

You can find a tutorial here: http://itsfoss.com/how-to-connect-kindle-fire-hd-with-ubuntu-12-10/


There is an app that you install to the kindle fireHD and I believe it is free...ES something just go to apps and search starting with es...it is a file manager similar to goodreader(for you folks that use the ipad, goodreader is indispensable, think it costs a few bucks)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.