4
The following packages have unmet dependencies:
       gstreamer0.10-ffmpeg: Depends: libavcodec-extra-53 (>= 4:0.7-1) but    4:0.7.2.1ubuntu2 is to be installed
                         Depends: libavformat-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                         Depends: libavutil-extra-51 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                         Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                         Depends: libglib2.0-0 (>= 2.24.0) but 2.32.3-0ubuntu1 is to be installed
                         Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed
                         Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                         Depends: liborc-0.4-0 (>= 1:0.4.14) but 1:0.4.16-1ubuntu2 is to be installed
                         Depends: libpostproc-extra-52 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                         Depends: libswscale-extra-2 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed gstreamer0.10-ffmpeg:i386:    Depends: libavcodec-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to   be installed
                              Depends: libavformat-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                              Depends: libavutil-extra-51 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                              Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                              Depends: libglib2.0-0 (>= 2.24.0) but 2.32.3-0ubuntu1 is to be installed
                              Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed
                              Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                              Depends: liborc-0.4-0 (>= 1:0.4.14) but 1:0.4.16-1ubuntu2 is to be installed
                              Depends: libpostproc-extra-52 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                              Depends: libswscale-extra-2 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed



       Package dependencies cannot be resolved
       This error could be caused by required additional software packages    which are missing or not installable. Furthermore there could be a    conflict between software packages which are not allowed to be    installed at the same time.

I have tried to follow every instruction from here and it has still not helped me.

What is the problem and how do I fix it ?

Edit:
My problem is that I can't install Gstreamer ffmpeg video plug-in codecs to play .mpeg, .divx, .mpeg4, .ac3, .wmv and .asf files

  • Please try a sudo apt-get update first, and then see if you still get this error. – ish Aug 18 '12 at 16:18
  • Additionally would have helped if you mentioned what your are trying to install – doug Aug 18 '12 at 16:24
  • i dont have any problem with update .. what my problem is i cant install Gstreamer ffmpeg video plugin codecs to play mpeg , divx , mpeg4 , ac3 ,wmv and asf files – santosamaru Aug 18 '12 at 16:25
4

You appear to be using very outdated libraries, for example "libavcodec-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed". That version was released in 12.04 dev on 2011-12-26 and has been Superseded numerous times.

The current 12.04 version is 4:0.8.3ubuntu0.12.04.1) precise-security

So open software sources, software-properties-gtk & make sure that under Ubuntu Software the 1st 4 are checked & under Updates the 1st. 2 are checked

Then update your sources & see

  • i do what you say but its still giving the same Unmet dependencies ? – santosamaru Aug 18 '12 at 17:19
  • 1
    Could you open up software sources, switch to the main server, the run sudo apt-get clean && sudo apt-get update. Post the results in ubuntu pastebin & link in your question – doug Aug 18 '12 at 19:33
  • For me this doesn't work.. :/ – Pithikos Mar 11 '13 at 14:29
  • The mian server trick worked, I do not know why don't the other servers update regularly. I was using a PK server and had been trying to solve the issue for 2 days. Set it to main-server and it worked. – S. A. Malik Jun 2 '13 at 6:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.