I have made a custom icon for burg loader for my Lenovo Recovery Partition.I have made 3 icons :

large_qdrive.png (128 X 128 pixels)
small_qdrive.png (24 X 24 pixels)
grey_qdrive.png  (128 x 128 pixels)

The .png icons that I created I made them using gimp from a qdrive.ico file that I found in the Lenovo Recovery Partition.

I transferred the icons to the /boot/burg/themes/icons folder and I added to the class list of the grey,large,small and the hover files the following lines :

-qdrive { image = "$$/large_qdrive.png" } in the large file
-qdrive { image = "$$/small_qdrive.png" } in the small file
-qdrive { image = "$$/grey_qdrive.png" } in the grey file
-qdrive { image = "$$/grey_qdrive.png:$$/large_qdrive.png" } in the hover file

I ran sudo update-burg and after that I modified the following line in the burg.cfg file :

menuentry "Windows 7 (loader) (on /dev/sda2)" --class windows --class os {


menuentry "Windows 7 (loader) (on /dev/sda2)" --class qdrive --class os {

and I also tried to change the title for the Lenovo Recovery Partition,so I tried this as well:

menuentry "Lenovo Recovery Partition (on /dev/sda2)" --class qdrive --class os {

None of this tries enforced actually burg loader to use the custom icon that I made and I can't figure out why.

I have to mention also that there are a few themes that I have installed in burg which actually are able to use the small_qdrive.png icon that I made,but all the others which use either the large_qdrive.png or the grey_qdrive.png weren't able to use the custom icons.

I have double checked for typos in all the files that I have created or I modified,so I am pretty sure that I haven't misspelled anything.

I have checked also the title of the custom icons that I made and neither of them have a typo.

I have looked also if there are any other folder that the themes might use to retrieve the icons,but it seems that all of them except for **Fortune** theme,which I downloaded from OMG!UBUNTU,use the icons folder which is located in /boot/burg/themes/icons

I tried to add the custom icons to the icons folder of the theme **Fortune**,but still nothing happened.


Interesting..... I didn't actually know that there was a specific place to put custom icons (or precisely, where it was XD). I do know, however, that when I made custom icons for my BURG install (using Lightness) I just stuck them in with the rest of the icons under /boot/burg/themes/Lightness/somewhere and changed the file in there that came along with it (the changes you made, I think).

TL:DR Try making those text changes in the theme-specific folder instead in addition if applicable.

  • Thanks for your answer,but it has been a long time since I was trying to do that mod on burg.I actually had to reinstall Ubuntu because of a problem with the NVidia Xserver Settings program.So right now burg isn't installed in my PC.But once again thanks again for your help.Maybe I will try to do it again in the near future. :) – und3rd06012 Nov 26 '12 at 6:36
  • haha ok then. Maybe vote to close your q if it no longer relevant? – WindowsEscapist Nov 26 '12 at 14:36

I think the issue is that the class needs to be declared. I am working on this myself as I run pearOS and it is not recognized in burg so the icon is just a question mark. This article shows some of the steps required but I think not all. I'll post again if I get this figured out!


You have to take special care how you save the icons using gimp. burg is very picky about the png's it supports. Make sure you untick all checkboxes when exporting your png's. Here you have the files I created for my xbmc class which are working for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.