I've just upgraded my 32-bit Xubuntu 10.04 system to 64-bit 12.04 (Core 2 Duo) and am getting consistent errors on my Crucial SSD which causes it to remount in read-only mode after about an hour of using the system. Sometimes it seems the cause is heavy I/O installing new applications (it's a fresh install) while other times it fails while sitting idle.

Bug #992424 describes the issue with several people confirming it and others posting kernels that work for them. It was originally reported in February, but the latest activity seems to be early June. I've tried these kernels with no success:

  • 3.2.29 (installed with Xubuntu 12.04)
  • 3.1.5
  • 3.0.41
  • 3.0.17

What should I try next? I think the next step is to install 11.10 and hope the problem was introduced with 12.04, but I'm wondering if perhaps there could be a 32- vs. 64-bit issue here. It's a Dell Vostro 200 with a 64-bit Core 2 Duo, so I installed the 64-bit version, but I was running the 32-bit version before with no trouble. This all started immediately after installing 64-bit 12.04.

If it matters, I first installed over my existing 10.04 system hoping to keep most settings in tact. When I got the first errors, I did a clean install and copied over only my non-configuration home directory files.


Check for firmware and driver updates.

A few days later my coworker experienced the same errors on her machine without having updated or altered her installation in any way. After restarting, about an hour later her machine would experience problems due to the SSD being remounted in read-only mode. This was the exact same problem I was having.

Given that we installed the same brand of SSD on the same day, we decided to investigate this as a hardware issue. It turns out that this particular brand of SSD was shipped with a firmware bug that starts causing read errors after 3,154 hours of cumulative uptime. The errors disappear after a restart but reappear after one hour thereafter, forever.

Updating the Crucial m4 64GB SSD's firmware to version 000F solved this issue.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.