When ever i press Space in Rhythmbox the song starts over instead of going on pause and when its on pause and i press Space the song starts over again instead of resuming from where it left of.

So my question is how can i change this so it will toggle between pause/play?

  • Does this Q&A help - if so, we should perhaps close this as a dupe: askubuntu.com/questions/181651/… – fossfreedom Aug 30 '12 at 12:12
  • no, i want to change the "CTRL" + "SPACE" in the program to only "SPACE", so i can press space to toggle between pause and play, and it must only be while the program is open(not minimized just like how the "CTRL" + "SPACE" is now). – Jeggy Sep 1 '12 at 15:38

rythymbox's keyboard interface is incoherent.

The desired behaviour, (which imo is desired behaviour for all music players at all times,) of space bar being play/pause button, is actually possible after you click play or pause with the mouse. It is like it 'selects' that button.

However, after you select a track for example, the spacebar behaviour changes to selecting that track, so everytime you press pause, I mean spacebar, it will again select that track, and because it is playing it will start playing the track again. I hope this will get fixed sometime into something more sensible and intuitive. Like the desired behaviour.

| improve this answer | |

You would need to change the source, as space in a tree typically means "activate the current selection." And this describes the behavior you're seeing exactly.

However, it does appear that pressing Ctrl+Space gives your desired behavior.

| improve this answer | |
  • thanks :D do you know how i can change it so when i press "CTRL" the same will happen as when pressing "CTRL"+"SPACE" ? – Jeggy Aug 17 '12 at 18:30
  • As Ctrl is a modifier key, you can't really make it do something when you press only that key. You will have to press it along with another key. If you want a single key for play/pause, I'd recommend a multimedia keyboard if you don't already have one. If you do have one, the play/pause key on it should do what you want. :) – dobey Aug 17 '12 at 20:07
  • sorry i wrote wrong, i meant "SPACE" not "CTRL" – Jeggy Aug 17 '12 at 21:25

You are ~probably supposed to also be able to change the setting for global play-pause in gnome-control-center -> All Settings -> Keyboard -> Play (or Play/Pause), which I think is by default set to Control-Space.

But, it won't let you set Space as an option since that would conflict with other applications. It's also not working for me at the moment; there might be other pieces of gnome that I don't have loaded cause I'm not running a full gnome desktop.

This isn't really a solution, but at least provides a bit more info on the misbehaving subsystems.

| improve this answer | |
  • also, in the time it takes rhythmbox to load, cmus can index your entire library from scratch. use space, tab, and arrow keys to navigate, then the c key is you play/pause button. Don't try to play an aac file, or it will blast static at a deafening volume. – Andrew Wagner Apr 15 '15 at 8:54
  • Why isn't this answer on the top?! – Tanny Jun 10 '16 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.