1

In older versions of Ubuntu with Compiz, I liked using Super + arrow key (up, down, left, right) to immediately go to a different desktop wall. I set up the same shortcut keys in Ubuntu 12.04 with CompizConfig Settings Manager, but now I must press the Enter key to commit the desktop wall choice.

For example, I want Super + Right to jump to the right virtual desktop without pressing the Enter key to commit the change.

This may be related to question: https://askubuntu.com/questions/126117/alt-tab-in-12-04-requires-pressing-enter-to-select-app-can-i-disable-that but that is a problem with the application switcher, this is about the desktop switcher.

1

Just figured this out, although my method loses the "Live Preview" of the desktops. In CompizConfig, go to Desktop Wall, uncheck "Show Viewport Switcher Preview", and you no longer need to press Enter to commit the switch. The desktop will be switched immediately after animating.

0

I have struggled with this for months, and finally found a solution without disabling Live Preview!

It seems like a conflict with Super shortcut being used by Unity Launcher. Isolate Unity Launcher to another key (but not Super Key).

Change Unity Launcher shortcut to something else (Under Compiz Config Settings Manager/Unity Plugin, i changed "key to show the launcher" to Control ).

Then go back to CCSM / Desktop Wall / Bindings, and try to use again the Super + Directional Keys. It will work OK, without asking for Enter, and do the desktop switching like 11.10 .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.