I was able to successfully juju bootstrap, but get an error with juju status. Here is what I got the first time I ran it:

Please type 'yes' or 'no': The authenticity of host 'node-003048c0cd2a.mydomain.com (' can't be established.
ECDSA key fingerprint is f8:02:18:7c:24:b6:99:20:cc:ab:29:d0:bc:c4:d7:20.
Are you sure you want to continue connecting (yes/no)? yes
2012-05-22 05:55:55,411 ERROR Invalid SSH key
2012-05-22 05:56:24,390 ERROR Invalid SSH key
2012-05-22 05:56:54,623 ERROR Invalid SSH key

Before running bootstrap or status, I created my ssh keys and added the generated public key to the preferences of my user account on the MAAS UI.

Any ideas why I am getting this SSH error? This error still occurs hours after the nodes install. I have not changed the names of any nodes, DNS is correct, and I can ping the FQDN of the nodes in the web UI.

2 Answers 2


Things to check:

  1. Have the nodes finished installing?

  2. Any chance you edited the bootstrap node name from the MAAS node interface?

  3. Is your DNS still pointing in the right place?

One more thing - are the clocks reasonably accurate on the maas server and on the nodes? If they are too far out of sync, it makes OAuth fail which currently silently breaks the metadata access from the commissioning node, which makes it just sit at a login prompt instead of finishing the commissioning process and rebooting.


Once you do juju bootstrap, you must reboot your nodes - they will install new software, and the necessary keys to stop this griping from ssh.

  • I am having the problem again. If this worked as of very recently, but has stopped working, where should i go looking for troubleshooting help? Nov 21, 2012 at 4:50
  • There is no need to reboot your nodes.
    – dimitern
    Oct 14, 2014 at 7:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.