I tried to set up a test cloud by following the tutorial here: https://wiki.ubuntu.com/ServerTeam/MAAS

I successfully set up the MAAS server and set it as a DHCP server. Then I tried to add some nodes via the maas dashboard. I entered the mac addresses of 2 computers on the lan network and after a while I saw they had been added to the list of nodes with a status of "commissioning". In the home page of the MAAS dash board it showed 2 nodes that were both offline. I have enabled wake-on-lan on both of the computers(on the NIC that I have connected to the lan of course, the NIC I took the MAC address from for each computer) but they wouldn't boot so I tried booting them manually, one of the two computers showed me a list of what I suppose they are images, the other didn't. On the computer that did show the list I choose on of the images and it continued booting, at some point it hung while waiting for network connection. Anyway I decided to remove the nodes from the MAAS server and try to recommission them using the installation usb/DVD but I found out I couldn't remove them from the dashboard because they were "Commissioning", I tried to find a way to stop them from commissioning but I couldn't so here I am, looking for help.

Actually, I just rechecked. The bios setting was Boot from lan not wake on lan, scratch that. Anyway, I booted them manually. The message is the same on one of the computers:

Begin: Running /scripts/local-bottom ... done done Begin: Running /scripts/init-bottom ... Success: root-ro successfully set up ro/tmpfs-rw layered root is using overlayfs done

[ 9.663259] r8169 0000:01:08.0: eth0: link down [ 9.663605] ADDRCONF(NETDEV_UP): eth0: link is not ready

Ok, more info. The second computer(the one that didn't show the list) is ready. I checked the boot order and set the network card first and it worked. It now shows up as "ready" on the dashboard and I can start it from there, I have no idea however how to log in to my node if I want to, I never set any users or passwords. :S

The other one now. If I choose local or maas-enlist on from the list, it starts a process similar to the installation of the ubuntu server(looks for a network link, tries to autoconfigure ipv6, successfully configures networking with DHCP) and then starts loading additional components. At some point it says Sending SiGTERM adn then Sending SIGkill to all processes and shuts down, if I restart it, the whole thing happens again. If I choose local, it tries to boot from the first hard drive which I suppose is what it should do, if I choose the i386 something option, the installation process starts regularly, if I wait, the same thing with maas-enlist happens.

I forgot, if I choose the i386-commissioning option the eth0 thingy happens.

Nevermind, it wasn't solved. Here's the current situation: Computer 1: Everything ok, Shown as ready in the node list,shown as queued on the main page. Can't login on the node, don't know credentials.

Computer 2: I installed maas-precise-i386, I can boot and it shows me "maas-precise-i836 login:" on the screen, Node shown as "Commissioning" in the node list, shown as offline on the main page.


Computer 1: If you have added your SSH key to MAAS, it should be placed on Computer 1 when it starts up and you can do ssh ubuntu@computer1

Computer 2: you should use maas-enlist and then go to the UI to 'Accept and commission' the new node. After that, the commissioning process should start and then you should get in the same state than computer 1.

As for deletion of the nodes, it's not currently possible to do that when their state is "commissioning". We are looking at implementing a watchdog in the near future that will mark them as "failed" if they don't complete commissioning in time (see bug 981082), however I may also add a utility script to do this manually if you don't want to wait for the timeout.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.