This whole problem began a few months back when I tried to transfer data from my external hdd (formatted to NTFS) to a computer using Windows 7. While in Ubuntu, there is about 1 TB worth of data (important things which I would rather not lose), but when I tried to access those files from Windows, they didn't show up

After lots of Googling and trying things, I did the following using a spare external HDD that I had (same manufacturer, same capacity) .

  • Formatted the spare drive to ext 4
  • Transferred every file from old drive to spare drive.
  • Reformatted old drive to NTFS using gparted
  • Transferred some files on to the old drive to test if it works on Windows, and it did.

Now the problem is, when I try plugging the old drive again in Ubuntu, it doesn't mount. I noticed this happens when the spare drive is already mounted. I have tried formatting the old drive to Ext4, FAT32 and again in NTFS but no luck so far.

I get this error message when trying to mount the spare drive with the old drive already mounted and a similar one when the drives are reversed:

Error mounting: mount exited with exit code 1: helper failed with:
mount: only root can mount /dev/sdc1 on /media/Seagate External

This is the result of trying to mount the drive via the terminal:

sebastian@ubuntu:~$ sudo mount /dev/sdc1
[sudo] password for sebastian:
ntfs-3g: Failed to access volume '/dev/sdc1': No such file or directory

ntfs-3g 2012.1.15AR.1 external FUSE 28 - Third Generation NTFS Driver
Configuration type 7, XATTRS are on, POSIX ACLS are on

Copyright (C) 2005-2007 Yura Pakhuchiy
Copyright (C) 2006-2009 Szabolcs Szakacsits
Copyright (C) 2007-2011 Jean-Pierre Andre
Copyright (C) 2009 Erik Larsson

Usage: ntfs-3g [-o option[,...]] <device|image_file> <mount_point>

Options: ro (read-only mount), remove_hiberfile, uid=, gid=,
umask=, fmask=, dmask=, streams_interface=.
Please see the details in the manual (type: man ntfs-3g).

Example: ntfs-3g /dev/sda1 /mnt/windows

News, support and information: http://tuxera.com
sebastian@ubuntu:~$ sudo mount /dev/sdd1
The disk contains an unclean file system (0, 0).
The file system wasn't safely closed on Windows. Fixing.
fuse: failed to access mountpoint /media/Seagate External_: No such file or directory 

This is the fstab, if it makes a difference:

# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc    /proc   proc    nodev,noexec,nosuid 0   0
/dev/sdd1   /media/Seagate\040External_ ntfs-3g defaults,nosuid,nodev,locale=en_US.UTF-8    0   0
/dev/sdc1   /media/Seagate\040External  ntfs-3g defaults,nosuid,nodev,locale=en_US.UTF-8    0   0
/dev/sdc1   /media/sdc1 ntfs-3g defaults,locale=en_US.UTF-8 0   0
/dev/sdc2   /media/sdc2 ext4    defaults    0   0
/host/ubuntu/disks/root.disk    /   ext4    loop,errors=remount-ro  0   1
/host/ubuntu/disks/swap.disk    none    swap    loop,sw 0   0

I should also mention that the old drive originally had a second partition of ~100 GB with nothing on it.

Any insights would be appreciated.


Your fstab entries are messed up. You are trying to mount the same device in two different places, and one of them with two different filesystems. You shouldn't have any fstab entries at all for external media; they will be automatically mounted when inserted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.