9

When I first installed Ubuntu, all networking worked perfectly. After messing with the settings every so often, it slowly became unusable. I would really like to know if there is a way to completely reset network settings without re-installing Ubuntu, DNS settings, proxy settings, everything. I'm running 12.04.

3 Answers 3

5

It depends what sort of connection you have and whether you have had to manually tweak some settings for it, as sometimes you need to do in the case of a wireless connection.

If you have a wired connection and have simply been altering the settings with Network Manager, you can unplug your Ethernet cable, go into Network Manager and delete all the wired connections (eth0, autoethernet, etc) and then reboot. This has worked for me before. On restart, your wired network will be detected and automatically configured with DHCP to set up ip addresses and DNS settings. This assumes, however, you have a dynamic ip address: you will still have to specify some settings manually if not.

If you have manually altered any settings such as disabling DNSmasq or manually specifying nameservers by creating a fixed resolv.conf, or even changing firewall settings, then you will need to reverse these first and then remove your connections from network manager and reboot.

If none of these approaches are successful, you may need to login to your router and check the settings there.

1

You can flush your iptables which firestarter has changed with

sudo iptables -F

Source: Post on Ubuntu forums

3
  • That fixed some of the problems I had earlier this week, but it still fails to stream video or times out when loading certain sites 19 out of 20 times (just an approximation). Any idea what could be causing these issues? It works fine on other computers on my network, or if I wire directly into the modem. Yes, I've tried resetting the router.
    – tyjkenn
    Aug 18, 2012 at 4:38
  • Sorry, I don't know to fix this problem, but may find some help on ubuntuforums.org
    – Zignd
    Aug 18, 2012 at 11:37
  • 5
    This may fix a few problems but certainly does not answer the question.
    – mchid
    Jul 19, 2016 at 9:38
-1

Warning: I don't really know what this recovery option does and I tried to find some info on it but was unsuccessful. While searching however, I found a more detailed description of the steps I took to fix my issue:

https://www.osradar.com/enable-network-ubuntu-recovery-mode/

I was having an issue where I was not being issued an IPV4 address on some networks, this prevented me from using most sites other than Google, and also KDE was also not functioning on some networks. I am using Ubuntu 22.04. This is what seemed to help with me:

  1. Reboot
  2. Press space bar while rebooting to access grub, or whatever key it may be for you.
  3. Go down to "Advanced options for Ubuntu" hit enter
  4. A new menu should popup, there should be a few options, one being "Ubuntu, with Linux some kernel version (recovery mode)" The important option here being (recovery mode). Select this one and hit enter.
  5. This opened a new window with various options, one being "network .... Enable networking" Choose this
  6. It'll ask you if you want to mount your system in read/write mode, select yes.
  7. After this a small terminal popped up, some commands seemed to run, and that was it, then I rebooted and my networking issues were fixed.
1
  • I don't see how just only enabling networking on recovery mode could fix any issue. Are you sure you didn't run any extra commands? Aug 5, 2022 at 19:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .