16

Possible Duplicate:
My sound stopped working today, how can I fix it?

I'm baffled by this discrepancy:

  1. This speaker test is successful:

    speaker-test -c 6 -D 'surround51:CARD=PCH,DEV=0'
    
  2. Sound Settings is behaving as if I have no sound card:

    Sound Settings

How do I find out what's causing this problem?

Details

Have a look at aplay -L, pacmd list-cards, lshw, pulseaudio -vvvv, and pavucontrol. I do not use HDMI.

This discussion of a similar problem on a PulseAudio mailing list suggests that changes to /etc/pulse/default.pa might be responsible, but I have not edited this file.

6

Turns out I was running into Bug #590780: Installing "randomsound" package causes Pulseaudio to stop functioning at reboot and didn't know it yet. See this answer:

  1. Run pstree | less
  2. In that, type /arecord and press return to find the arecord process.
  3. Press up once and you'll see its parent. In my case this was randomsound.
| improve this answer | |
0

Have you tried to rebuild the alsa sound module? If no, try the following:

sudo apt install module-assistant build-essential

sudo module-assistant prepare,update

sudo module-assistant build,install alsa

sudo depmod

This should reset your sound settings.

| improve this answer | |
  • 1
    Which "sound settings" does this reset, and why do you recommend doing this? I'm not yet convinced that the problem is within ALSA, since it appears to detect my sound cards correctly. – ændrük Aug 16 '12 at 1:38
  • "Sound settings" corresponding to the image you linked above in your question. ALSA y detecting your sound card but isn't showing it in the "selec device" section. after this it should show it. – blackedx Aug 16 '12 at 2:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.