Recently, I upgraded the RAM and hard drive on my Early 2008 Macbook to improve the performance. Rather than throw away the old hard drive, I bought an enclosure for it to turn it into an external hard drive, and, since all the data was migrated to my new drive, I decided to install Ubuntu on it for funsies (note: I am a near-total Ubuntu n00b).

My first attempt to install Ubuntu didn't work (it gave me errors about not being able to find the BIOS or something), but my second attempt finished successfully (can't remember what, if anything, I did different).

However, when I plug the external drive into my Macbook, it gives me a message saying it can't read the disk. Moreover, when I go into the Startup Manager (i.e.: what you get when you turn on the Macbook while holding the option key), the external drive is not one of the available startup disks. I thought this might be because I have an older Macbook, so I tried booting it with my mom's Late 2011 Macbook, and got the same results. Then I tried booting it through my dad's Dell laptop that runs Windows 7, and that time it worked. This is really counter intuitive to me, since the hard drive originally came from a Macbook, so if anything you'd think it would be less compatible with the Windows laptop than the Macbook.

In case it helps, here's a link to a picture of how I set up the partition table while doing the install (not shown there is the fact that I checked the "Format?" box next to the /boot partition, since it gave me a warning when I tried to continue the installation without doing so)

enter image description here

Anyone have any clue at all? If it helps, the hard drive I'm using is a 120GB 5400-rpm Serial ATA hard disk drive.

  • 1
    Maybe because the drive is formatted to ext4. Mac cannot read drives in this format. Try formatting it in the ext3 format and then reinstall Ubuntu. – Akshit Baunthiyal Aug 15 '12 at 16:25
  • Tried that, still having the same problem. Did a bit of Googling, and it seems Mac OSX Lion can't read any of the ext file system formats. However, you've still helped me by cluing me in to what the cause of the problem is. I've done some searching, and it seems that my best options are either rEFIt or some sort of FUSE-based solution to make my Mac read/write ext filesystems. Unless someone here knows a better way? – Catgirl the Crazy Aug 17 '12 at 13:20

First of all your drive needs to be formatted with the GUID partition table (changed by clicking the options button when partitioning in Disk Utility),

Why because Intel Macs can only boot from GUID hard drives. Second you should be able to boot using rEFIt, but rEFIt must be installed on a External drive E.G. CD, USB etc, and not on the internal Hard Drive as rEFIt supports booting from ext formatted hard drives

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.