I'm running a dual boot with 12.04 and Windows 7 installed. I don't use Windows that often, so I decided to try and remove the boot menu to start up quicker. So far, the menu appears to not display, yet my screen still displays a blank screen with the distinctive "orange thingy" for approximately ten seconds.

Several forums I have read have instructed me to edit the etc/default/grub file to change the timeout to zero. I have done this, updated grub and restarted, yet this screen still persists.

Grub file currently reads as:

GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"

I have automatic login enabled and it takes approximately 35 seconds to go from powering on to my system being loaded. This is with a fresh install two days ago and my processor is an Intel® Core™ i3 CPU M 370 @ 2.40GHz × 4.

Can someone please tell me if my computer is simply too slow to boot up any faster, or if there is step I have skipping in removing the boot screen?

Any other information would be appreciated.

  • 1
    You must uncomment the second line of your /etc/default/grub file, and also remove the quotation (" ") marks on the zero values. So from #GRUB_HIDDEN_TIMEOUT="0" TO GRUB_HIDDEN_TIMEOUT=0 – Peachy Aug 15 '12 at 13:02

my screen still displays a blank screen with the distinctive orangey tinge for approximately ten seconds

Isn't this the Ubuntu loading screen? If this is a screen that you used to see after the GRUB menu before, then it's already booting as fast as it can; when you see that screen GRUB has already been skipped.

If you want to optimize your boot time more, I'd suggest you turn on verbose boot (to see all the text output during the boot) and see where it stops. If it stops at certain points that are unnecessary, you might be able to disable those checks completely to boot faster.

What you've done so far is just to skip the boot selection, this in itself only shaves off as many seconds as you used to have as a timeout for the default selection. It's often not more than 3-5 seconds. Whatever is shown after that selection is all OS.

| improve this answer | |
  • Thanks bigbadon, I thought it might be possible that it was OS loading but I wasn't sure. I thought there might be something up since after the orangey tinge ubuntu loaded up remarkably quickly. The Ubuntu logo that it displays whilst loading it only displayed for about half second and the progress bar filled up almost immediately. I tried mspeachy's suggestion but no difference. I did a quick google about verbose, but most post relating to altering grub seemed to relate to turning off. Would please you be able to direct me how to turn on verbose? – Billy Aug 17 '12 at 13:07
  • Actually, on further investigation, what I'd found to enable to verbose boot was working, but an unclosed { was interfering. Thanks for your help! – Billy Aug 18 '12 at 4:22
  • Glad you solved it :) – pzkpfw Aug 24 '12 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.