Possible Duplicate:
What is the easiest way to resolve apt-get BADSIG GPG errors?

Of late, I've been getting this long list of errors every time I run apt-get update from the terminal. These errors weren't there before, I have no clue how they cropped up all of a sudden. I even tried some methods as suggested in some forums, but they apparently haven't worked for me so far. I've even tried changing the server, but to no avail. I'd be really glad to receive help on this issue.

The errors are here: http://paste.ubuntu.com/544093/


Type the following in your terminal one by one,

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 2E206FF0

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 17CF995E

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 298C1C9F

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E21DD54D

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 5139BD61

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 9E5DB0C8

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 4631BBEA

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 0624A220


  • After running all the above commands you may get few errors, because i have found lot of errors in your result,post the complete output of sudo apt-get update after running all those commands.So that i may help you.
| improve this answer | |
  • You can also make this one command and separate the keys with blanks. :) – htorque Dec 19 '10 at 15:31

Is there a transparent proxy between you and the Ubuntu archive? It seems that several of the Packages files are not being fetched correctly (which results in the GPG failures). Try this from the command line:

curl -I http://extras.ubuntu.com/ubuntu/dists/maverick/Release

Does that show something like this? (The first line showing "200 OK" would be expected if things aren't totally broken.)

HTTP/1.1 200 OK
Date: Thu, 23 Dec 2010 21:08:06 GMT
Server: Apache/2.2.8 (Ubuntu)
Last-Modified: Sun, 10 Oct 2010 23:00:00 GMT
ETag: "f72018-dfca-4924b34083c00"
Accept-Ranges: bytes
Content-Length: 57290
Content-Type: text/plain

If this looks clean, try it again:

sudo apt-get clean
sudo apt-get update
| improve this answer | |

Run the following in terminal,

sudo apt-key adv --keyserver pgp.mit.edu --recv-keys 5044912E

sudo apt-get install ubuntu-extras-keyring

sudo apt-get update


  • If you get any errors after running the above commands,post the output here.
| improve this answer | |
  • I did as you told. This is what I got on apt-get update: paste.ubuntu.com/546976 – Pawan Neupane Dec 23 '10 at 17:09
  • @Pawan-Neupane Delete the old keys first and then import the key. – karthick87 Dec 23 '10 at 17:13
  • I'm sorry but how do I delete old keys? All the keys or just those two? – Pawan Neupane Dec 23 '10 at 17:35
  • @Pawan-Neupane Goto Software sources>>Authentication tab and then delete the following keys 40976EAF437D05B5 FC918B335044912E 16126D3A3E5C1192 – karthick87 Dec 23 '10 at 17:39
  • I removed the three keys you mentioned. Then, executed the three commands you suggested earlier. That didn't help either. So I repeated the first command for all three keys again. Still to no avail. Here's what I still get: paste.ubuntu.com/546987 – Pawan Neupane Dec 23 '10 at 17:51
sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install launchpad-getkeys
sudo launchpad-getkeys

Keep me informed

| improve this answer | |
  • @Karthick87, is your question answered? – Ilias Feb 14 '11 at 10:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.