The sound through my speakers is fine, however it cracks/popples when played through my headphones. While looking for a solution, I found this. I tested this by unplugging my headphones, plugging them in again, and then quickly playing sound through them. The sound sounds file for ten seconds, then it starts crackling and popping again. However, there is no

options snd-hda-intel power_save=10 power_save_controller=N

in my alsa-base.conf file. Is there an alternate parameter that I can change?

  • Just checking, you use an alternate port on your sound card for headphones?
    – jeremija
    Aug 15 '12 at 8:36
  • @jeremija: I am using a USB port with an M-Audio FastTrack MKII for sound. It has worked fine in previous installations (running an older version of Ubuntu).
    – Zach Latta
    Aug 15 '12 at 8:52
  • It seems really weird because that's actually the same stereo channel, plugging the headphones in just makes the soundcard redirect the main output to headphones, right?
    – jeremija
    Aug 15 '12 at 9:03
  • @jeremija: Plugging the FastTrack adds two more output channels called 'Digital Output (S/PDIF)' and 'Analog Output'. Both output sounds through the headphones.
    – Zach Latta
    Aug 15 '12 at 9:16

You could try this:

Try resetting your pulse configuration.

Using a Terminal="Applications->Accessories->Terminal"

rm -r ~/.pulse ~/.asound* ~/.pulse-cookie 
sudo rm /etc/asound.conf

Reboot and ignore any 'No such file or directory' errors

  • I tried that previously to no avail. I just tried it again and nothing changed.
    – Zach Latta
    Aug 15 '12 at 9:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.