Kind of similar to this, I paired my Bluetooth headset (Turtle Beach Ear Force PX5) in Ubuntu and it at first showed up in "Sound Settings" after pairing. It was not initially working, so I started tweaking some settings. I tweaked a setting on the microphone, and all of a sudden both the output/input device disappeared. The device works with Windows, although to get it to work with my phone simultaneously (the headset is 2ch) I usually disable the microphone and only enable it when needed.

I captured the debug output from bluetoothd:

bluetoothd[31789]: audio/headset.c:headset_connect_cb() /org/bluez/31789/hci0/dev_00_13_8A_4E_64_03: Connected to 00:13:8A:4E:64:03
bluetoothd[31789]: audio/headset.c:handle_event() Received AT+BRSF=9
bluetoothd[31789]: audio/headset.c:print_hf_features() HFP HF features: "EC and/or NR function" "Voice recognition activation" 
bluetoothd[31789]: audio/headset.c:handle_event() Received AT+CIND=?
bluetoothd[31789]: audio/headset.c:handle_event() Received AT+CIND?
bluetoothd[31789]: audio/headset.c:handle_event() Received AT+CMER=3, 0, 0, 1
bluetoothd[31789]: audio/headset.c:event_reporting() Event reporting (CMER): mode=3, ind=1
bluetoothd[31789]: audio/headset.c:hfp_slc_complete() HFP Service Level Connection established
bluetoothd[31789]: audio/telephony.c:telephony_device_connected() telephony-dummy: device 0x7fa1944b6f10 connected
bluetoothd[31789]: audio/headset.c:headset_set_state() State changed /org/bluez/31789/hci0/dev_00_13_8A_4E_64_03: HEADSET_STATE_CONNECTING -> HEADSET_STATE_CONNECTED
bluetoothd[31789]: audio/media.c:headset_state_changed() 
bluetoothd[31789]: audio/avdtp.c:avdtp_ref() 0x7fa1944b9e00: ref=2
bluetoothd[31789]: audio/avdtp.c:avdtp_ref() 0x7fa1944b9e00: ref=3
bluetoothd[31789]: audio/sink.c:sink_set_state() State changed /org/bluez/31789/hci0/dev_00_13_8A_4E_64_03: SINK_STATE_DISCONNECTED -> SINK_STATE_CONNECTING
bluetoothd[31789]: audio/avdtp.c:avdtp_unref() 0x7fa1944b9e00: ref=2
bluetoothd[31789]: Connection refused (111)
bluetoothd[31789]: audio/avdtp.c:connection_lost() Disconnected from 00:13:8A:4E:64:03
bluetoothd[31789]: audio/avdtp.c:avdtp_unref() 0x7fa1944b9e00: ref=1
bluetoothd[31789]: audio/sink.c:sink_set_state() State changed /org/bluez/31789/hci0/dev_00_13_8A_4E_64_03: SINK_STATE_CONNECTING -> SINK_STATE_DISCONNECTED
bluetoothd[31789]: audio/sink.c:discovery_complete() connect:connect XCASE detected
bluetoothd[31789]: audio/sink.c:sink_set_state() State changed /org/bluez/31789/hci0/dev_00_13_8A_4E_64_03: SINK_STATE_DISCONNECTED -> SINK_STATE_DISCONNECTED
bluetoothd[31789]: audio/avdtp.c:avdtp_unref() 0x7fa1944b9e00: ref=0
bluetoothd[31789]: audio/avdtp.c:avdtp_unref() 0x7fa1944b9e00: freeing session and removing from list
bluetoothd[31789]: audio/unix.c:server_cb() Accepted new client connection on unix socket (fd=30)
bluetoothd[31789]: audio/sink.c:stream_setup_retry() Stream setup failed, after XCASE connect:connect

I've tried deleting and repairing the device, but it looks like I've set some persistent device setting accidentally in the depths and the device isn't showing up in Sound Settings anymore to allow me to change it. Does anyone have any pointers? I'm running Ubuntu 12.04.


2 Answers 2


Found my answer here:

Get rid of 0.5s latency when playing audio over Bluetooth with A2DP

blt@aurora:/$ pactl list cards short
0   alsa_card.pci-0000_01_00.1  module-alsa-card.c
1   alsa_card.usb-Generic_Turtle_Beach_USB_Headset_0000000001-00-Headset    module-alsa-card.c
2   alsa_card.pci-0000_00_14.2  module-alsa-card.c
8   bluez_card.C8_84_47_04_21_6F    module-bluetooth-device.c

blt@aurora:/$ pactl set-card-profile bluez_card.C8_84_47_04_21_6F a2dp

and it works again

  • 2
    that worked! I don't really think that this should have been closed...it isn't an exact duplicate, just the solution is the same. Aug 16, 2012 at 17:28
  • @azurewraith I agree that it's reasonable to reopen this, since the problem is so different. The other alternative would be to edit that question (to which this has been duped) to generalize it (so it covers more problems). However, even though I've voted to reopen this question, I recommend this answer be expanded through editing (by its author, you, or anyone else who can) to explain why that technique worked here, even though this situation is so different from the one there. Apr 1, 2013 at 21:31
  • I imagine that the issue was with the BT device profile getting stuck as something other than a2dp. I was not able to get it to switch back to a2dp from the UI. From the link above, it is established that flip-flopping BT profiles causes PulseAudio to re-initialize/re-sync the audio. It seems this forced my device to go back to the proper mode to where PulseAudio could show it in Sound Settings. The OS instance has been wiped since then, so this is purely conjecture. Apr 2, 2013 at 1:22

I had the same issue where I was tweaking my sound settings and suddenly my bluetooth headset disappeared from the Output list.

I followed the link from Brett's answer and partially followed Roelf's answer:

  1. Install pavucontrol: sudo apt install pavucontrol
  2. Run pavucontrol from the menu
  3. Go to 'Configuration'
  4. My bluetooth headset has a mic too, so I changed the profile setting to 'Output + Analogue Mono input'

My headset and mic reappeared in the sound settings after I changed this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .