I installed wolf:et, and i cant get sound to work. Everything that i have installed is in default paths, i had 10.4 and then upgraded to 10.10 via software update gui. I had sound working in 10.04 with method under 2.

I have tried following

  1. killall esd; et; esd

    with that i get

    ------- sound initialization -------
    /dev/adsp: No such file or directory
    Could not open /dev/adsp

  2. sudo -i
    echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
    echo "et.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss

    with that i get

    bash: /proc/asound/card0/pcm0p/oss: No such file or directory
    and indeed i do not have that, i have only sub0 and sub1 in pcm0p

  3. I have tried running et with et-sdl-sound script, but with that i get this output in console
    I have probably messed up sdl libraries, could not get sound to work, so downloaded new from debian package site and installed them.

  4. Tried setting SDL_AUDIODRIVER="pulse" in et-sdl-sound, looks like i am getting same error as in method 3.

  5. pasuspender -- et +set s_alsa_pcm plughw:0

    gives me

    ------- sound initialization -------
    /dev/adsp: No such file or directory
    Could not open /dev/adsp

Misc: @Oli: i do not know if i am running pulse or esd, how can i check that?


I got tired of rebooting to windows just to play wolf-et, so i tried doing clean install of ubuntu 10.10 (maverick).

And after that I just installed Wolfenstein: ET from playdeb and everything works great. http://www.playdeb.net/software/Enemy%20Territory


Not sure why you're running esd. I thought that was kicked out years ago for PulseAudio. If you don't have PulseAudio, I probably wouldn't follow the rest of this answer.

First, make sure SDL can talk directly to Pulseaudio:

sudo apt-get install libsdl1.2debian:i386 libsdl1.2debian

Then with the et-sdl-sound script, change SDL_AUDIODRIVER="alsa" to SDL_AUDIODRIVER="pulse".

Sound should magically start flowing into your ears and life will be much better.

Some people have also in the past had success with temporarily killing PulseAudio (to release the hardware) and manually setting the driver:

pasuspender -- et +set s_alsa_pcm plughw:0
  • Neither helps, i tried setting SDL_AUDIODRIVER="pulse", it still gives me error : can't locate libSDL.so And suspending pulse does not help too – grizwako Dec 15 '10 at 14:13
  • @GrizzLy Are you running PulseAudio still or have you stripped it out for ESD? – Oli Dec 15 '10 at 14:20

I bored to try to fix sound and desided to try to install wolfenstein enemy territory with wine.

It work (have some problems, but mostly work like it should be, with sound).

Here how you can install it:

  1. Install wine (if do not have it).

  2. Download wolfenstein et client for windows (Here: http://www.splashdamage.com/content/download-wolfenstein-enemy-territory). Extract it somewhere safe, like homefolder, and open terminal.

    Type: cd path to WolfET_2_60b_custom.exe file (example: cd /home/workspace ). Then do: wine WolfET_2_60b_custom.exe (wine open windows installer, run it).

  3. Download punkbuster and keygenerator (Here: http://etkey.org/pages/punkbuster/auto---install-for-windows-by-harlekin.php) Extract it and rightclick ET_PBSetup.exe and run with wine (install it in to wolfenstein folder).

  4. In your system, navigate in to /.wine/dosdevices/c:/Program Files/Wolfenstein (or there where you have installed wolfenstein et), rightclick et.exe and make link. Cut link, and paste it on to workspace.

  5. Reboot, lock in, doubleclick link_to_et.exe on your workspace, and have fun with et.


For 12.04, what worked for me was to use an SDL hack that's been done a few years back.

  1. Get SDL with ALSA options:

    sudo apt-get install libsdl1.2debian-alsa

  2. Once installed, get the hack:

    wget -q -O - http://nullkey.ath.cx/~stuff/et-sdl-sound/et-sdl-sound.gz | gzip -d > et-sdl-sound && chmod a+x et-sdl-sound

  3. Reboot your machine.

Once rebooted, instead of typing just et to run, this time type et-sdl-sound.


@Will Sams "2. Once installed, get the hack:

wget -q -O - http://nullkey.ath.cx/~stuff/et-sdl-sound/et-sdl-sound.gz | gzip -d > et-sdl-sound && chmod a+x et-sdl-sound" My terminal output for that was:

gzip: option --ascii ignored on this system

gzip: stdin: not in gzip format

Any help with this?


I have loaded the windows installer in wine and I have perfect sound, I think that any game with opengl wil work in wine, so try it out.

  • 1
    Hi Bart, welcome at askubuntu! Answers are intended to address the questions and help the original poster. It seems that this question is quite old already, and the problem was solved long time ago. – noleti Aug 30 '14 at 14:00
  • In this thread it did not help; ubuntuforums.org/showthread.php?t=2225114, so my solution was up to date. And the solution in this thread did not work either. – Bart Aug 30 '14 at 16:21

After you get the script, install the i386 version of libsdl1.2debian edit et-sdl-sound to point to that location. [and edit gamepath too]

More info here : https://wiki.debian.org/Games/WolfensteinEnemyTerritory

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.