20

I have enable FullScreenmode in Dosbox under Ubuntu 12.04 . But still i am not getting it in Fullscreen. My turbo c++ windows is less than my screen size.

32

First, press ctrl + F10 to lock mouse to dosbox and then try alt + Enter.

12

You need to edit dosbox-0.74.conf as given below

Go to terminal and type gedit /home/severus/.dosbox/dosbox-0.74.conf

and make these changes:

fullscreen=true
fulldouble=true
fullresolution=1366x768
windowresolution=1366x768

output=opengl #MOST IMPORTANT

autolock=true

Now save the file and open dosbox. It should be fullscreen with full workspace.

NOTE : Original source of this answer : Click Here

4
  • Goto /home/user/dosbox.conf
  • Find resolution
  • Change fullresolution from original to your choice (eg. fullresolution=640x480)
  • Leave windowresolution intact (i.e, windowresolution=original) as you might want a smaller sized window.

Optional: change fullscreen to true (i.e, fullscreen=true) if you want to start dosbox in fullscreen mode

1

I think the Alt-Enter command makes DOSBox go full-screen. That might not be your problem, though.

  • This is the right answer for my problem (which was escaping full screen after alt tab) – George Dimitriadis Jul 21 '17 at 10:27
0
fullresolution=auto
windowresolution=auto

for me auto setting on these two functions, works better.

Ctrl+F10 is for accessing mouse

Alt+Enter is to switch from full screen to small.

0

Severus Tux solution worked on my raspberry pi, but took up far too much computing power. Extreme lag and overheating followed from just rendering the dos prompt.

Another solution is to change the "scaler" parameter to a size that fits your screen the best. you can either double, or tripple the number of pixels used:

scaler=normal2x forced

or

scaler=normal3x forced

pick the one that fits your fullscreen mode the best.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.