I'm trying to mount an hfsplus filesystem in a Xubuntu 12.04 VM (kernel version 3.2.0-23-generic) but when I type mount -o remount,rw /dev/sdb3 in command line it returns not mounted or bad option. Any help would be appreciated.


6 Answers 6


The correct syntax is:

sudo mount -o remount,rw /partition/identifier /mount/point

Where mount/point is /partition/identifier's corresponding mountpoint, as listed by the following command:

mount -v | grep "^/" | awk '{print "\nPartition identifier: " $1  "\n Mountpoint: "  $3}'

For example, say that the above command gives this:

Partition identifier: /dev/sda1
 Mountpoint: /    

Partition identifier: /dev/sda2
 Mountpoint: /boot

Partition identifier: /dev/sda3
 Mountpoint: /test

The following would be the correct syntax. (We start by unmounting it, if it's already mounted.)

sudo umount /test
sudo umount /dev/sdb3
sudo mount -t hfsplus -o rw,remount -force /dev/sdb3 /media/untitled
  • Thanks for the response! I have been using sudo, forgot to include that. I'm by no means an advanced linux user, so I'm not exactly sure what I'm supposed to be seeing in /etc/fstab. However, when i type "df -h" it tells me that the hfsplus filesystem is mounted at /dev/sdb3
    – Alkthree
    Commented Aug 14, 2012 at 14:21
  • 1
    I see what you're saying now, "mount -v | grep ^/" returns "/devsdb3 on /media/untitled". I tried "sudo mount -o remount,rw /media/untitled" and got the same problem-not mounted or bad option.
    – Alkthree
    Commented Aug 14, 2012 at 14:32
  • Have you tried sudo mountall?
    – SirCharlo
    Commented Aug 14, 2012 at 14:42
  • Let's continue this discussion in chat..
    – SirCharlo
    Commented Aug 14, 2012 at 14:45
  • 1
    Oh come on! That simple.. Good for you! :P In order to help clean up the site, please post the steps you took as an answer to your question and then accept your answer. This will prevent your questions from showing up in the Unanswered section. Thank you!
    – SirCharlo
    Commented Aug 14, 2012 at 19:38

for busybox/android users:

Oddly, I needed to add a space (in contrast to normal usage) between 'remount' and 'rw':

mount -o remount, rw /

otherwise it wouldn't work.

UPDATE: it seems that this is almost never the case (see comments). Not sure which busybox-version + android-version I was running. I'll just leave this here in case anyone still runs into it.

  • 3
    I did not need an extra space on my Busybox implementation. Or did you mean busybox and Android? My busybox is within an embedded controller (not a smart phone)....
    – wallyk
    Commented May 9, 2016 at 22:22
  • 1
    Had to do this on plain Ubuntu too.
    – DustWolf
    Commented Sep 2, 2016 at 18:01
  • 1
    what a strange syntax
    – phil294
    Commented Feb 27, 2018 at 21:09
  • @wallyk i found this out when I ssh'ed into my rooted android (busybox is a necessary app in the playstore). It might have been an old version of busybox, as it was android v2 dot something. Commented Mar 12, 2018 at 9:37
  • This worked for me... mount -o remount,rw rootfs / since my /proc/mounts has rootfs / rootfs ro,seclabel,relatime 0 0
    – Ray Foss
    Commented Sep 7, 2020 at 2:43

Running dmesg | grep hfs showed that the filesystem was unmounted incorrectly, which I was able to repair using

fsck.hfsplus /dev/sdb3/

First, let us fix NTFS problems (if you have an Ubuntu/Windows dual boot setup)

sudo ntfsfix /dev/sda7

Before mounting we need a Directory (folder)

mkdir ~/Desktop/disk

Now mount the partition

sudo mount /dev/sda7 ~Desktop/disk

In this case "sda7" is the partition name. Now you read from and write to the partition.


I have Dragonboard 410c I connecting via adb I wanted to mount the physical sdcard as RW. the following worked for me.

adb root
adb shell
mount -o remount,rw /storage/sdcard1   /storage/sdcard1

So I can now access it in rw mode as /storage/sdcard1

nb. /storage/sdcard0 is emulated and is /sdcard


First I typed mount to see the results and determine the mapping I wanted altered to full access was /media/linux/OLD_PC.

This worked fine to unlock the files and folders within my old Windows system partition.

sudo mount -o remount,rw /media/linux/OLD_PC  /media/linux/OLD_PC

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .