154

I'm trying to mount an hfsplus filesystem in a Xubuntu 12.04 VM (kernel version 3.2.0-23-generic) but when I type mount -o remount,rw /dev/sdb3 in command line it returns not mounted or bad option. Any help would be appreciated.

213

The correct syntax is:

sudo mount -o remount,rw /partition/identifier /mount/point

Where mount/point is /partition/identifier's corresponding mountpoint, as listed by the following command:

mount -v | grep "^/" | awk '{print "\nPartition identifier: " $1  "\n Mountpoint: "  $3}'

For example, say that the above command gives this:

Partition identifier: /dev/sda1
 Mountpoint: /    

Partition identifier: /dev/sda2
 Mountpoint: /boot

Partition identifier: /dev/sda3
 Mountpoint: /test

The following would be the correct syntax. (We start by unmounting it, if it's already mounted.)

sudo umount /test
sudo umount /dev/sdb3
sudo mount -t hfsplus -o rw,remount -force /dev/sdb3 /media/untitled
  • Thanks for the response! I have been using sudo, forgot to include that. I'm by no means an advanced linux user, so I'm not exactly sure what I'm supposed to be seeing in /etc/fstab. However, when i type "df -h" it tells me that the hfsplus filesystem is mounted at /dev/sdb3 – Alkthree Aug 14 '12 at 14:21
  • I see what you're saying now, "mount -v | grep ^/" returns "/devsdb3 on /media/untitled". I tried "sudo mount -o remount,rw /media/untitled" and got the same problem-not mounted or bad option. – Alkthree Aug 14 '12 at 14:32
  • Have you tried sudo mountall? – SirCharlo Aug 14 '12 at 14:42
  • Let's continue this discussion in chat.. – SirCharlo Aug 14 '12 at 14:45
  • 1
    Oh come on! That simple.. Good for you! :P In order to help clean up the site, please post the steps you took as an answer to your question and then accept your answer. This will prevent your questions from showing up in the Unanswered section. Thank you! – SirCharlo Aug 14 '12 at 19:38
26

for busybox/android users:

you need to add a space (in contrast to normal usage) between 'remount' and 'rw':

mount -o remount, rw /

otherwise it won't work.

  • 2
    I did not need an extra space on my Busybox implementation. Or did you mean busybox and Android? My busybox is within an embedded controller (not a smart phone).... – wallyk May 9 '16 at 22:22
  • 1
    Had to do this on plain Ubuntu too. – DustWolf Sep 2 '16 at 18:01
  • what a strange syntax – Blauhirn Feb 27 '18 at 21:09
  • @wallyk i found this out when I ssh'ed into my rooted android (busybox is a necessary app in the playstore). It might have been an old version of busybox, as it was android v2 dot something. – coderofsalvation Mar 12 '18 at 9:37
4

Running dmesg | grep hfs showed that the filesystem was unmounted incorrectly, which I was able to repair using

fsck.hfsplus /dev/sdb3/
1

I have Dragonboard 410c I connecting via adb I wanted to mount the physical sdcard as RW. the following worked for me.

adb root
adb shell
su
mount -o remount,rw /storage/sdcard1   /storage/sdcard1

So I can now access it in rw mode as /storage/sdcard1

nb. /storage/sdcard0 is emulated and is /sdcard

1

first, let fix NTFS problem (if you're you dual boot "windows and ubuntu")

sudo ntfsfix /dev/sda7

before go to mount we need a Directory(file)

mkdir ~/Desktop/disk

now mount

sudo mount /dev/sda7 ~Desktop/disk

in this cause "sda7" is hard disk partition name, now you read and write dis

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.