0

I need to change AHCI module in Ubuntu, and I've always uses ahci.blacklist=yes.

But now it doesn't work bcause AHCI is built-in the kernel, and CONFIG_SATA_AHCI=y not CONFIG_SATA_AHCI=m.

What can I do now? Please help me.

1

Try adding modprobe.blacklist=module_name to the kernel parameters to blacklist the loading of the module at boot time. You can still insert it later if you need.

So, in the case of the AHCI driver, pass modprobe.blacklist=ahci to the kernel.

2
  • Does this actually work in this case? The point of the question seems to be that modprobe.blacklist=ahci only works if the ahci driver is compiled as a module, and the question is how to blacklist the driver when it is built into the kernel. – njsg Nov 24 '16 at 10:40
  • @njsg, you are correct, I tested it again to be sure. I also verified that the new 4.8 kernel parameter module_blacklist=module_name does not work with built-ins either. The only option is the rebuild the kernel with CONFIG_SATA_AHCI=mand use the modprobe.blacklist or module_blacklist with 4.8+ kernels. – Lucas Nov 30 '16 at 18:18
0

According to the Fedora Common Kernel Problems wiki page, to disable AHCI you can add rdblacklist=ahci to the boot parameters and disable the functionality. It warns that this should make the system slower.

To add a kernel option, edit the grub configuration file:

gksu gedit /etc/default/grub

Add in the option you need to the GRUB_CMDLINE_LINUX_DEFAULT line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=bios rdblacklist=ahci"

Save the file and now regenerate the grub menu using:

gksu update-grub
1
  • Thanks for your answer, but it still not work on ubuntu 12.04, AHCI still loaded when boot ahci 0000:00:11.0: version 3.0 ahci 0000:00:11.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22 ahci 0000:00:11.0: irq 40 for MSI/MSI-X ahci 0000:00:11.0: AHCI 0001.0100 32 slots 6 ports 3 Gpbs 0x3f impl RAID mode ahci 0000:00:11.0: flags: 64bit ncq sntf ilck pm led clo pmp pio slum part ccc scsi0 : ahci scsi1 : ahci scsi2 : ahci scsi3 : ahci scsi4 : ahci scsi5 : ahci – user83278 Aug 15 '12 at 1:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.