After an update some months ago, my laptop has begun making a low, repeated clicking sound every few seconds. It is not being generated through the regular sound system, as altering the volume and even muting the sound does not make any difference. My regular audio works fine, by the way, so I am guessing this is some sort of PC speaker, since I cannot hear the click when I listen through regular headphones.

Strangely, when I open the sound settings dialog the click magically disappears. I don't need to change any settings; if I simply leave the dialog open in the background then the problem disappears.

Any ideas what this could be?
I am running regular Ubuntu 12.04, and this is the output from lspci -v | grep -A7 -i "audio":

00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
    Subsystem: Acer Incorporated [ALI] Device 0349
    Flags: bus master, fast devsel, latency 0, IRQ 44
    Memory at 54200000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd-hda-intel
  • I have exactly the same problem, with an HP laptop rather than an Acer.
    – foglerit
    Commented Sep 23, 2012 at 9:10
  • 1
    More recently I noticed that it only happens when my laptop is unplugged and running on batteries. Have you noticed the same @jonnat ? Commented Sep 25, 2012 at 13:51
  • Yes, exactly the same wrt plugged/unplugged.
    – foglerit
    Commented Nov 13, 2012 at 2:43
  • I have the same problem on Acer e1-571G, I think it is notification sound of plug and unpluging sth like battry or maybe a secondry HDD(that i recently added to my laptop);
    – ako
    Commented Jan 28, 2018 at 18:15

7 Answers 7


It seems that the problem resides within the Intel High Definition Audio drivers, and it has been around for quite some time now.

To solve the problem temporarily, but immediately, issue the following command:

echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save

Try the previous command to be sure you are suffering this problem. If this works for you, then you can solve it permanently by adding the following line above "exit 0" in "/etc/rc.local".

echo 0 > /sys/module/snd_hda_intel/parameters/power_save

Hope this helps

Sources: post 1 post 2

  • 1
    This solution worked on an Acer Aspire 5733. Thanks a mill guys! Commented Oct 7, 2012 at 18:12
  • 1
    Thanks for your help! The first line worked, but adding the second line to /etc/rc.local does not seem to make a difference; The problem returns each time I unplug the laptop or wake it from sleeping (while unplugged). I have to run the first command every time to stop the clicking, but maybe this can be set permanently somewhere? Thanks again. Commented Oct 15, 2012 at 20:35
  • worked on an acer 5742 ubuntu 12.04. Thanks a lot !
    – Elvis
    Commented Nov 23, 2012 at 10:52
  • This also works on my Fedora workstation with an Asustek card. Funny note: before the fix, when I played silence, the clicking stopped. At the end of the clip, the clicking is back.
    – Davidmh
    Commented Oct 8, 2018 at 13:35
  • 6
    On modern systems that do not use /etc/rc.local this option can be set permanently by adding options snd-hda-intel power_save=0 to /etc/modprobe.d/alsa-info.conf. See bugs.launchpad.net/ubuntu/+source/linux/+bug/1825754/comments/… Commented Jan 4, 2020 at 18:08

taken from these threads:

how to execute a command after resume from suspend?



create a script named hda-fix and place it in /etc/pm or somewhere in your home dir if you prefer. It should contain:

sleep 5
echo 0 > /sys/module/snd_hda_intel/parameters/power_save
exit 0

in folder /etc/pm/sleep.d create a script named say 30_hda-fix containing

case $1 in
        exec /etc/pm/hda-fix &

similarly, for when you unplug the power, drop a similar script in /etc/pm/power.d

case $1 in
         exec /etc/pm/hda-fix &

for some reason the script is not executing well if you do it instantaneously; the crackling is activated after the scripts are running; therefore, u need a second script that is run and waits for the cracking to start before it executes. the & in the exec line in the scripts avoids the master script from blocking; this is the only way I found to accomplish the execution of the command after the cracking has started. I looked at the at command but it only handles minutes so this was my workaround


Relates to: Ubuntu 16.04

For me the opposite was working. Put following into: /etc/modprobe.d/alsa-base.conf

options snd-hda-intel power_save=1 power_save_controller=Y

/sys/module/snd_hda_intel/parameters/power_save was already 0, however every time playing a sound the ticking is back for a short while but will be deactivated then by the power manager.


In case anybody else sees this. For me it was happening because the power coming in was so weak the computer kept flipping between charging and not charging. Short term fix was just to turn on system sounds, long term fix will be to figure out why it's not charging very well.


It's the audio device going in and out of standby. It's a power saving feature. I'm not sure whether there is a way to put it in an out of standby without a click, that's what I'd like to know.
I also have an Acer laptop. I'm on Debian and originally did not have this issue, but then I ran powertop --auto-tune and now I do.
If it's any consolation, these clicks are a sign that you are saving a little battery power!


For me on Dell xps13 9333 with tlp installed the solution was to edit my tlp settings (in /etc/default/tlp), setting: SOUND_POWER_SAVE_ON_AC=0 SOUND_POWER_SAVE_ON_BAT=0 SOUND_POWER_SAVE_CONTROLLER=N


In my case it was a problem with my laptop charger: a loose connection would make it so that the computer repeatedly switched between running on AC vs. running on battery.

You can check whether this might be the case for you, too, by observing the power/battery symbol in the task bar: if you're plugged in but the symbol indicates you're running on battery, check your cable connections.

If nothing is obviously loose, the cable might be broken internally at which point it is a good idea to replace it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .