I am trying to install a couple Windows programs. I have tried Wine itself, PlayOnLinux & Crossover. No matter which one I try, I get the same error message: "access denied" I tried logging in as root, thinking this would work, but still got the same results. I am running Ubuntu 12.04, 32 bit. ADDITIONAL DETAILS AS REQUESTED: I am using installation CD's. I have been able to install Windows programs before, so this is a new problem that occurred after updating my system. All was fine before that. The install files are on the CD's. Permissions? I assume so since as I said, I had installed other Windows software without issue BEFORE the upgrade. And yes, I have checked compatibility & all 3 programs are said to work well in Wine/Crossover.

The prgrams I am trying to install are: 1. Age Of Empires III(Crossover rank: Gold) 2. Quicken 2011 (Crossover rank: Silver) 3. Steam (Crossover rank: Silver)

UPDATE: Iright click on the .exe file & allow executing as program is not selected. Also, it wont let me change them, says permissions could not be changed.

  • 1
    Would you mind adding more information. Is it a single .exe/.msi file? Is it located in a separated partition? Does the file have execution permissions? – Ángel Araya Aug 13 '12 at 5:08
  • I have edited the question – LinuxPCplus Aug 13 '12 at 5:34
  • You can't change the permissions because you're using a read only media. I would recommend you to use the Play On Linux installer (last version possible, look in the PPA). Other than that, I don't see why you get the error. – Ángel Araya Aug 13 '12 at 19:50
  • You could be running into a bug that is affecting the way the Ubuntu kernel and Wine are(or are not) getting along...try running echo 0|sudo tee /proc/sys/kernel/yama/ptrace_scope in a terminal and try installing again...Note this workaround will lower your security until the next reboot, the lower security is minimal for Desktop users but is still true...IF it works for installing you may or may not need to use it to run the programs. It may not work at all but is worth a try as it will not hurt anything if it fails(assuming you reboot to reset the workaround) – TrailRider Aug 15 '12 at 1:59

Well, obviously the windows installer needs permissions! I had the same problem! I did the following:

  • I burned the CD into an ISO imagefile
  • Then i mounted the ISO file with the FuriusIso Mount
  • After that, i opened a terminal and typed: gksudo nautilus (it will open a file browser with root access!)
  • Now find the mounted ISO path and edit the installer file's properties
  • Done!

Good Luck!


wine is just an emulator so the windows programm emutlator so sometimes wine can not run windows programms ...

go Wime HQ site and look if your programm supported ...

  • I have tried PlayOnLinux Angel, it gives the same results. Jemadux, as I said in my question, all 3 of the programs are said to work well in Wine AND in Crossover. All three Have at least a silver rating by Codeweavers (makers of Crossover). And I am aware of WHAT Wine is. – LinuxPCplus Aug 13 '12 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.