I have a Dell Vostro 3460 with one of the new Broadcom 43142 hybrid Wireless/Bluetooth chips. Neither the proprietary driver (wl) nor the b43 driver supports this.

lspci -nn gives me

01:00.0 Network controller [0280]: Broadcom Corporation Device [14e4:4365] (rev 01)
02:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8161 Gigabit Ethernet [1969:1091] (rev 10)

I manage to install 1969:1091 with compat-wireless' alx, but could not find any alternative for this Broadcom 4365...

Do you guys know any driver for this controller? I am seriously considering to buy a compatible USB card?


3 Answers 3



Drivers for this are only officially available with the Vostro 3460 as provided by Dell.

However, based on the instructions and the Dell deb from the Vostro 3560 provided in this forum thread, I have created a modified DEB file that compiles and installs the driver on 12.04 (see thread for 11.10 link).

First, install the prerequisites by opening a terminal and pasting, one line at a time:

sudo apt-get install linux-headers$(uname -r | grep -Po "\-[a-z].*")
sudo apt-get install build-essential dkms

Please download the appropriate DEB file from Dropbox here:

Open a terminal, and install it with sudo dpkg -i.

Hopefully it works!

Edit: 12.04 now has an updated bcmwl-kernel-source package that reportedly supports BCM43142. bug#923809, comment 15

  • Thanks for replying @izy. Is there any alternative driver for 12.04/10 32 bit? Commented Aug 13, 2012 at 5:02
  • The linked file should compile on 32-bit. Doesn't it?
    – ish
    Commented Aug 13, 2012 at 5:03
  • I get a dpkg error: package architecture (amd64) does not match system (i386) Commented Aug 13, 2012 at 5:05
  • @rodrigo: please see edited answer, download the 32-bit package and you should be good to go.
    – ish
    Commented Aug 13, 2012 at 9:04
  • sorry for the delay to get back on this, and thanks for providing the 32-bit version. I tried with both Ubuntu 11.10 and 12.10, but got similar dpkg errors: .../build/src/wl/sys/wl_linux.c:50:24: fatal error: asm/system.h: N compilation terminated. Am I missing anything? Commented Aug 15, 2012 at 3:51


Please verify your pci.id with a terminal command:

    lspci -nn

Is it 14e4:4365? I am not sure it is even possible in a 32-bit system. If you have a 64-bit system and the device I mentioned, then I suggest this package: http://jas.gemnetworks.com/debian/pool/main/w/wireless-bcm43142/wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb

First install the prerequisites:

    sudo apt-get install linux-headers-generic build-essential dkms

Then install the package with:

    cd Desktop   <--or wherever you downloaded the deb
    sudo dpkg -i wire*.deb
    sudo modprobe wl
  • 2
    This solution worked with Ubuntu 12.10 64-bit
    – tiangolo
    Commented Nov 17, 2012 at 20:30

I tried following method to install Broadcom wireless Driver with Dell Vostro 3500 in Ubuntu/Xubuntu 12.04 (64 bit) Linux.

First of all check your wireless chipset model number,

lspci | grep Network

Install following prerequisites,

sudo apt-get install linux-headers-generic build-essential dkms

Download following package and install,


Open the following file:

gedit /etc/modprobe.d/blacklist.conf

Add the following lines:

blacklist b43
blacklist b43legacy
blacklist bcma
blacklist ndiswrapper

Comment the following line,

# blacklist bcm43xx

Restart your laptop and check whether the wireless is working or not.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .