Yesterday I just turned on my Ubuntu machine and I decided to try Xubuntu. I installed it and everything worked fine. After a few hours I saw that the machine loses Wireless signal every 5-10 seconds and gets it back after a few seconds. I didn't know what to do, so I decided to reinstall Ubuntu. I did that, installed Xubuntu again, Wireless was working fine.

Today I turned on my machine and saw that it can't even connect to the Wireless network. I just keep connecting but it just can't connect. Where could be the problem? I tried to uninstall Xubuntu but that didn't help. Wireless signal is very good, because I'm working with another Windows machine and it's great. And I don't think that laptop's hardware is broken, because yesterday when I was installing Ubuntu he got the wireless signal without any problems.

I'm using IBM ThinkPad R51 laptop. Yesterday I was using Ubuntu 12.04, but today I've installed 11.10 on my machine. By the way, here's the output of the command sudo lspci -nn: http://pastebin.com/GZweXHW0

02:02.0 Network controller [0280]: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection [8086:4220] (rev 05)

So, do you have any ideas where is the problem?

EDIT: somehow it has connected to the wireless. I'll try using it and I'll tell if I have any problems and if it keeps disconnecting or something.

EDIT1: I've noticed that after upgrading to 12.04 Wireless doesn't show anything, like there'd be no available Wireless spots, but the internet is working... It's connected to the router which is at my home. Strange...

closed as off-topic by Eric Carvalho, Aaron, waltinator, TheWanderer, Zanna Sep 30 '16 at 8:24

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Eric Carvalho, Aaron, waltinator, TheWanderer, Zanna
If this question can be reworded to fit the rules in the help center, please edit the question.


This was my issue too, which is described in more detail here.

The solution was to change the settings on the router, for how to do that see this forum post.

You can try by starting at the router and setting your security to WEP; if it works, gradually increase the level of security until it doesn't. My card is Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05) and it works just fine.

Not the answer you're looking for? Browse other questions tagged or ask your own question.