I have installed Ubuntu 12.04 64bit version. I have no problem with it until we tried to take a backup by using Acronis True Image software.

Normally, Ubuntu was seen under BIOS menu under "EFI Boot" option. Then, there was a problem with this software and Ubuntu is lost from the EFI Boot menu. Then, Ubuntu cannot boot.

I have used the Boot-Repair software given in the following link.

I have followed the steps given in recommended solution. I have installed GParted, deleted the FAT32 boot partition and created an unformatted partition with bios_grub flag as recommended by the Boot-Repair software.

After completing the recommended boot repair operation, now the Ubuntu starts but gives an error as described in the title.

The disk drive /boot/efi is not ready yet or not present Error. 
Continue to wait or Press S to skip mounting or M for manual recovery. 

If I press S, I can login Ubuntu and use it without any problem.

Also, I have checked and seen that under BIOS menu, Ubuntu still does not exist under EFI boot options. I have searched for the solution in forums and tried the recommended solutions given in the following link, but they did not work.

Please help to solve this problem, can I disable the EFI boot option from Ubuntu?

up vote 1 down vote accepted

Edit your /etc/fstab file and comment out or remove the entry for /boot/efi; that should do away with the error message. You're now booting Ubuntu in BIOS mode, not in EFI mode, so you no longer need the /boot/efi partition. (That partition is the "FAT32 boot partition" you referred to earlier, also known as the EFI System Partition, or ESP.)

That said, my suspicion is that you're booting Windows in EFI mode. If so, you'll probably need to use your firmware's boot manager to select which OS to boot. That might or might not be convenient. If you prefer to use something else (GRUB Legacy, GRUB 2, rEFIt, rEFInd, or whatever), you'll need to get EFI booting working again for Linux. By deleting the ESP and re-creating a fresh one, you also deleted the EFI-mode boot loader for Linux. The fix you followed was the hard way to do it; the easy way was to boot into EFI mode (using the Ubuntu installer, say) and use the efibootmgr program to add the Linux EFI boot loader (probably GRUB 2) back to the NVRAM options. You can still do this, but you'll have to uninstall grub-pc and re-install grub-efi. This will entail jumping through a number of hoops. Alternatively, you could switch to something else, such as GRUB Legacy, ELILO, or the kernel's EFI stub loader (if you're using a 3.3.0 or later kernel). See my Web page on EFI boot loaders for much more information on these options. Overall, if you're happy selecting your OS the way you're doing it now, it's probably easier to stick to that method, at least in the short term.

  • Thank you very much for your support and detailed answer. When I commented the line as you mentioned, now it's ok, directly boots. I am using only Ubuntu, not dual operating systems. So, is it necessary to use EFI? Is there any advantage to use it? I will check your web page in a spare time to learn the details of EFI. Best Regards, Fikret – user82752 Aug 13 '12 at 7:13
  • There are a number of advantages to booting with EFI, but they're all either quite minor or they're important only when multi-booting with another OS. The biggest for a Linux-only computer is probably that, on some systems, EFI booting is faster than BIOS booting. You also get a different set of boot loaders and boot managers for EFI than for BIOS, and you might prefer an EFI boot loader to a BIOS one. Overall, though, it sounds like the maxim "if it ain't broke, don't fix it" applies to you right now. – Rod Smith Aug 14 '12 at 16:59

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.