With the release of Ubuntu 14.04, this question may not be relevant any more. This one (Making Canon LBP6000 printer work under Ubuntu 14.04 64-bit) might be more helpful.

This is really frustrating. I am trying to install LBP6000 in Ubuntu 12.04 without any success.

(Well, I had success about a week back when I first bought the printer and finally printed pages after a struggle of several hours. Then today it suddenly stopped working and I uninstalled everything and started from scratch. Now, I seem to have lost the way.)

My steps

  1. Downloaded the latest Canon driver from Canon site. File Linux_CAPT_PrinterDriver_V240_uk_EN.tar.gz
  2. Got the radu script (http://radu.cotescu.com/how-to-install-canon-lbp-printers-in-ubuntu/)
  3. Changed the /etc/modprobe.d/blacklist-cups-usblp.conf file as instructed in, Official Documentation. (See the section Ubuntu 12.04 Install). Now this file looks like,

    # cups talks to the raw USB devices, so we need to blacklist usblp to avoid
    # grabbing them
    # blacklist usblp
  4. Rebooted my machine

  5. Changed the port in radu script to 59787 as instructed in the link at step 3. (Again see the section Ubuntu 12.04 Install, or see the comment at How to Install Canon LBP Printers in Ubuntu. Also put the latest deb files from step 1 in the appropriate directory of this script.

  6. Ran the radu script. A printer, LBP6000 got added. Not two printers, one to be disabled, as appeared in the message on the terminal after running the script.

  7. sudo /etc/init.d/ccpd status shows,

    Canon Printer Daemon for CUPS: ccpd: 3142 3139


  8. The printer does not print. Printer state (from System Setting->Printing, or at cups http interface localhost:631/printers/LBP6000) goes from Idle to Processing, a job appears in print queue, and then the job disappears and the printer state goes back to Idle. The actual printer does not even blink.

Diagnostics (got help from the link in step 3, Troubleshooting)

  1. captstatusui -P LBP6000 shows communication error

  2. lsmod | grep usblp did not show anything. After running, sudo modprobe usblp, shows

    usblp                  17885  0

    However, ls -l /dev/usb/lp0 gives,

    ls: cannot access /dev/usb/lp0: No such file or directory

  3. /var/ccpd did not exist, created,

    sudo mkdir /var/ccpd
    sudo mkfifo /var/ccpd/fifo0
    sudo chown -R lp:lp /var/ccpd

Any suggestion will be appreciated. Do not know what to do.


This may sound odd but has worked for me - "generically" ie not that specific printer.

Your steps seem sound.. Go through them again ie.. purge the driver(s).

Re-install this time WITHOUT the printer plugged in. reboot or log in/out Connect printer and try to print.

Good Luck - Mal

  • The problem is now solved. All that was missing was to turn the printer off and then on again. So odd for a USB device. – Masroor Aug 11 '12 at 8:08
  • I find that now I need to run this script at every boot before the printer prints, #!/bin/bash pkill -9 -x ccpd pkill -9 -x captmoncnabc /etc/init.d/ccpd start /etc/init.d/ccpd status – Masroor Oct 30 '12 at 3:45

Operates as follows:

Install gs-esp_8.71.dfsg.2-0ubuntu7_all.deb

Then download raducotescu-CanonCAPTdriver-release-2.4-0-gc8ea9f9

Unpack and install

sudo. / canonLBP_install.sh LBP6000

Just something you need to mention for the LBP6000 with radu script:

  1. If you install the printer x86 with radu script, everything will be ok. But you cannot print (the printing job will be held for a while then, nothing happens).
  2. To fix this problem (it took me several days for figure out what happened), you please install the driver from the Canon side first, for the capt & common package from here:


After that, install the radu script:


It works for me now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.